Jump to content

2nd try - Help with Ethernet problem and Toshiba Laptop


4 posts in this topic

Recommended Posts

Hi there,

So I've recently tried installing Mac OS X 10.4.8 on my laptop. It works great, only I'm having trouble setting up a network. Now I'm very familiar with Windows, and how to set up an internet connection, Mac is a different story.

At first, I thought there was a problem with the driver. But apparently, the network card built in with my laptop (Toshiba Satellite A100) will run native on Mac. The thing is, when I hook up the network cable to my laptop, Mac does not pick up anything. I go in System Preferences and Network and it shows Built-In Ethernet but says the cable for blah blah is not plugged in. I try and click configure... but nothing happens. Now when I connect it says "An incorrect PPP option has been set. Please verify your settings and try again."

I've tried creating a new connection using the Network Assistant but I can't get passed "How do you Connect to the Internet?". All the options are grayed out and it's stuck on "I use a telephone modem to dial my ISP".

I've looked all over the forums, and thought I had to edit a Info.plist file at first, but then I figured that wasn't the problem as my built-in network card should be fine driver-wise to run native right?



Also, here's the information I put to set up my PPoE connection:



TCP/IP Connection Type:



DNS Hosts:

Left blank, how do I find this?


Domain name:

Left blank


Proxy Srever:

Left blank


Checked "Connect using PPoE"


Then on the following screen I fill out my username and password. I think it might have something to do with the DNS Hosts, I'm just not sure what to put here... Any suggestions on what I could do to figure out this problem?


(this was posted in another section of the forum but I didn't get any suggestions. Hopefully someone here will know what's wrong)


Thanks in advance for any help!

Link to comment
Share on other sites

First, if you haven't gone to Utilities > Disk Utility > selected your OSX Drive and Repaired Disk Permissions, do so before anything else.


I have a P205 but I suspect this will work for you.

Go to preferences > built-in ethernet > tcp/ip > on the pull down Configure Using menu select Manually.

If you have a router, it's address is probably or if you happen to know which, all the better.


Let's assume the router is at, enter as your IP Address (if it conflicts with another machine on the network, change the last number 10 to something else)


Set Subnet Mask to


Set Router to


Click the Apply Now button at the bottom of the window.


If you don't get a connection, change the 0 in the third IP group to 1, apply, see what happens.


On my machine, once I've forced the ethernet to activate, I can switch it to Configure Using DHCP and all is well.


If you still can't get it working, download the installer at: http://www.necnet.de/krass.man/Installers/...0Installer.html


Install, reboot, repair disk permissions, go through the above process again.


Good Luck

Link to comment
Share on other sites


  • Create New...