Jump to content

OSX86 on Laptop - Major problems, wasted days on this, help pls


4 posts in this topic

Recommended Posts

Got an ECS G551 laptop (click link for specs: http://www.ecs.com.tw/ECSWebSite/Products/...59&LanID=9)


, Ive tried 3 different OSX, and I always get some kind of error, that wont allow it to boot properly.. only time I actually got it to boot was with a 10.4.6 patched OSX86 install dvd, but then it wouldnt load without the install DVD in tray during bootup.. but after bootup with install DVD it worked fine, except from some minor bugs.. it found network card, soundcard, graphics driver, everything.. except ofcourse the AirPort driver for my intergrated Wifi card (any help there too?)


The first one I tried was:



and the guides I followed from projectx86 wiki wasnt all that good tbh, didnt explain anything about Diskutil and setting up drive..


but ofcourse, so n00b as I am, I chose install ALL, so it installed all kernels and whatnot, and that totally explains why it wouldnt work ofcourse.. it Froze at grey screen during bootup, and nothing would happen, I tried installing VIsta (since I used XP and the guides I used was for Vista/Osx dual boot), and installed over again this time only with SSE2 (which it supports, checked with CPUID) and the Intel package and this time with NO graphic card driver (as Ive read in MANY forums that this could cause freezup at grey screen)..


result? nothing, same as before, freezup.. really really annoying.. Ive probably installed and formatted and screwed up 5-6 times with xp/vista/osx, Xp/OSX, Vista/OSX, and just plain OSX.. nothing works..


Now ive installed Windows Vista from plain, then got to know EasyBCD and chain0 (which didnt work at ALL btw, dunno whats wrong), and I installed Uphuck 10.4.9 (same as before) on second partition.. I did as the guide says :

( http://coolblog.profit42.com/2006/12/09/vi...ot-on-intelamd/ ) . and I followed everything the guide said from Booting up in Vista with shrinking, diskpart active, then in Max OSX active etc etc..


I always get some kind of error.. everything from Kernel Panic, b0 error, to HFS+ Partition error, to Couldnt find /dev/somethingsomething.plist..


I really really want this to work.. Ive read many many guides, searched google for hours, and used probably 3-4 days at this..


can SOMEONE please help me here..


it looks so sweet having OSX on my laptop (the laptop in itself is pretty old 2-3 years or so, upgraded to 1gig ram and 80gig harddrive) especially now as school started I wanna sit there with my "crappy looking" laptop running SWEET ASS OSX and see the look on peoples faces :)


Hope to get some quick answer here.. any help on any subject I mentioned above would be helpfull, so dont think you have NO clue when you read this post if youve installed OSX on your computer.. just hit me guys, with everything youve got..


PS!! ==>> one last thing, when I installed Vista on it (which btw works GREAT and smoothly for just being 1.5 ghz, 1mb cache and 1gig ram, suprisingly well, almost like Im beginning to fall in love with Vista, which would be wrong, right?) it said that my motherboard was made by DELL, does this mean anything important contra installing OSX86?<<==PS!!

Link to comment
Share on other sites

1. if you get HFS+ Partition error, there are chances that you installed MACOSX on the third partition... check it out in vista-> computer management-> disk management.. usually a laptop come with a recovery partition which is about 1.5 GB and that is the first partition...

2. the http://coolblog.profit42.com guide works fine for me... i recommend uphuck 10.4.9 dvd because that is the most compatible version for most hardware.....

3. Keep trying!!!!!

Link to comment
Share on other sites

Thanks for the comeback guys, but the uphuck 10.4.9 is the version that doesnt work for me..


I tried a patched 10.4.6 version and it worked finally.. followed this guide to proper setup of MBR and bootloaders




But I still have to push F8 and get to Darwin bootloader when using Vista bootloader, otherwhise it automatically disables Darwin and returns me to Vista bootloader screen..


so, when I boot up, I get vistas booloader right with this information


Windows Vista Profesionall

OSX x86


then if I hit Windows Vista, it boots as normal, but if I hit OSX x86 and I wait it returns me to Vistas bootloader, but if I right after pushing OSX x86 hit F8 the darwin booloader comes up and shows me this:


Disk0s1 Windows NT

Disk0s2 OSX 10.4.6


and then if I hit OSX it starts up wonderfully..


is there a way for me to get a UBER bootloader which doesnt do any hazzle like vistas does?







1. Windows Vista

2. OSX 10.4.6


Choose your option and kick back relax while it boots up




and me without having to push F8 after choosing OSX, it would just bootup as with Darwin..



any ideas?

Link to comment
Share on other sites


  • Create New...