Jump to content

How to tell the diskutil about other harddisks?


7 posts in this topic

Recommended Posts

hi guys


i installed os x on a asus p5ld2 motherboard. my disk 0 is a s-ata disk with 2 partition, one for os x the other for win xp.

when logging in os x mounts both partitions.

but there are 4 other hard disks in my pc which are not mounted. even the disk util does not know them.


my setup:

1 sata disk

4 ide disks

1 ide dvd rom


the strange thing about this is: the IDE dvd rom is recognized and works perfect. but the hard disks are not recognized.


do you have any idea how to mount them? is there a tool available to search for them?


i tried "mount -u ntfs /dev/rdisk1 /Volumes/MyTestMount", so it told me the ntfs file system is unknown. I just nead read access there.


do you have any tricks?





Link to comment
Share on other sites

What version/installer are you using ? (i.e. jas 10.4.x etc..)


For me, it just picks up any disks i have plugged in. I used AppleNforceAta (added it) see this topic.


If i am not mistaken, this driver is (for me) only handling my SATA stuff, the original apple stuff is managing my IDE (from which i boot).

Link to comment
Share on other sites

i'm sorry :P


Using Asus P5LD2, running os x 10.4.9 by uphuck, cpu is intel dual core(not core duo!) 2.8ghz


According to the motherboard manual, those IDE ports can be used for hardware raiding as well. So I guess I need to have some kind of raid driver to access the disks? There are 3 IE ports on the board, 2 for raiding and 1 not raided. The dvde rom is on the one which is not raided and this one is also recognized...

Link to comment
Share on other sites

Which version of this board are you using. There are about three varieties floating around the VM, VM SE & VM DH which also supports raid. Various individuals around here state that raid doesn't work on this board. Check out the Diabolik's BIOS set up to see if you have it set correctly. http://forum.insanelymac.com/index.php?sho...85&hl=p5ld2


You state that you have Four IDE drives connected up. Have you tried connecting up with less. The reason I say this is because on the bios check the first 2 drives show as IDE and the 3rd & 4th show up as master when connected to SATA.


What I would also do is disconnect your SATA drive then load up the instal CD and go to disk utilities. Check to see if th IDE drives show up when it checks for available drives to install on. If they are then this might lead you believe its something to do with the bios settings or how you have the drives connected


Also Diabolik noted that the red E-IDE port does not work in Mac at the moment.

Link to comment
Share on other sites


  • Create New...