Jump to content

First try of OSX x86


12 posts in this topic

Recommended Posts

Hi guys,


I've been a lurker for a while, and with the amount of knowledge on this forum with regards to OSX x86 - I've decided to give it a shot on my Sony Vaio laptop and join here for help.


Last time I tried OS X on my PC was with PearPC and OS X 10.3 "Panther". The laptop has been a sitting duck as of late, so I'd thought I would make use of it with OS X x86.


I'm currently downloading Uphuck's 10.4.9 v1.3 image from Demonoid, and it should be completed soon.


Now on to the main specs of the laptop -


Sony Vaio FS215B


Intel Pentium M 740 @ 1.73GHz

1GB PNY PC2700 512MB x2

Intel 915GM mainboard

Intel GMA 900 w/128MB VRAM

Samsung 120GB PATA HD w/ 8MB cache

Pioneer DVR-K15 DVD-RW

Realtek ALC260 sound

Intel 100/VE ethernet

Intel 2200BG wireless


I've seen some screenshots of the "Customize" options when doing the OS X x86 install, but have no idea on what patches etc to choose (this is where you guys come in!)


Should the spec above be good enough? Will Core Image work?


Thanks for any help you can provide :thumbsup_anim:

Link to comment
Share on other sites

Make sure to choose the Intel package (if there is an option). Also pick the GMA900 driver package. That should be about it.

Link to comment
Share on other sites

Thanks for replying.


I've booted the DVD and chose the SSE2 option, GMA 900, Realtek audio and Intel 100/VE packages. Lets' see if it will work :police:


Spoke too soon, hehe ....


After the install finished, the laptop restarted and a blinking cursor just came up with no activity :/

Link to comment
Share on other sites

Right, made a bit more progress after looking around the forum.


The reason why the HD wasn't booting after install was because it had a GUID partition and not an MBR (which was fixed in Disk Utility), everything installed like it did after this.


Now OS X loads but stays on the grey loading screen with the circle active. I'm gonna repair the permissions on the disk, and if that doesn't work - gonna try Verbose mode.


Trying Verbose mode right now, and it stops at -


com.apple.syslogd: exited: Terminated

com.apple.vix.cron: exited: Terminated

com.apple.mDNSResponder: exited: Terminated

com.apple.nibindd: exited: Terminated

come.apple.KernelEventAgent: exited: Terminated


And ....


GFX0: family specific matching fails


And lastly ....


SystemStarter[41]: Waiting for application services


That's what is currently scrolling down the screen at the moment.

Link to comment
Share on other sites

Tried all the Universal kernels and the GMA 950 drivers as well, still the same.


Got a little bit forward though, after the Apple logo/loading logo the screen turns Aqua blue and it freezes (it didn't before).


Also partitioned the drive in half to see if that would have an effect with no joy.


Verbose mode still indicates the same output in my previous post, this time it's saying the "logonwindow.app = session setup failed (status = 226)"


Is it time to start another OSX x86 disk?

Link to comment
Share on other sites

i would reinstall without the viedo drivers and just make it use the default vga stuff.


NOTE: Im still new to this also i got everything working 100% about 2 weeks ago and im loving it. The main problem i had at first was i kept intalling the natit drivers for my x1600 and i would get the loginwindow freeze everytime so i reinstalled with no special drivers and then got a better ktext later.

Link to comment
Share on other sites

I tried JaS's 10.4.8 release with SSE2/SSE3, same issue came up. Tried Verbose & safe mode and it kept on hanging at -


GFX0: family specific matching fails


Then the blue background would come up and the laptop would freeze. I looked at the 10.4.8 HCL and my spec is more or less the same as the Sony FS-415M (minus the nVidia graphics) and I tried the options laid out there.

Link to comment
Share on other sites

Well, uphuck isn't really the best for intel systems.. maybe try the 10.4.8 JaS release.



Hi Ramm,


Actually I've had excellent results installing Uphuck's 10.4.9 on my Intel set-up more so than JaS 10.4.8...With Uphuck's, I got my Ethernet, DvD Player and my VGA chip fully working straight out of the box. Uphuck's release certainly has 'better' or more updated drivers and patches. I still can't get my wireless USB to work but it's not that important anyway.


Besides this, I think choosing compatible hardware is the main factor for success here, IMHO. In my main AMD set-up, I had to change my graphic card to get a successful boot and even then DvD Player still had some issues. My 'memory' sticks didn't show up in 'About This Mac' and everyonce in a while I need to 'restart' so that I can get a successful log-in.


From my very short experience in this whole OSX86 affair, I managed to conclude that Intel set-ups have far more rates of success than AMD ones, all other things being equal.



Link to comment
Share on other sites


  • Create New...