Jump to content

Vista, Boot Camp 1.3, Paralles 3.0 (4128)


2 posts in this topic

Recommended Posts

I just went about a completely fresh OS X 10.4.9 install with the goal of adding a Boot Camp partition for Vista that I could virtualize from within Parallels. I used the latest version of all software (well, 10.4.10 just came out yesterday...). My experience:

 

OS X installed and updated with Software Update. Boot Camp 1.3 installed created a 32GB partition for Windows. Vista Ultimate loaded on the Boot Camp partition and restarted. That when things started go slightly off-course:

 

Once in Vista I loaded my Boot Camp 1.3 driver CD and got it going. When it installed either the Bluetooth or Apple wireless keyboard and Mighty Mouse drivers (not sure which) my keyboard and mouse stopped working. Plugging in a USB version of both remedied the problem. Apparently this is a known by-product of the install but not necessarily a bug.

 

I rebooted Vista and lo and behold my Apple wireless keyboard worked when I held down the Alt key on start-up! I selected the Vista partition and it booted fine. On the Vista login screen, however, I couldn't type my password. Using the USB keyboard again got into Vista, removed the Mighty Mouse and keyboard from my Bluetooth devices, reinstalled them per the Boot Camp manual, and all is well. If I had to do it again I'd use the USB equipment on install and then install the Bluetooth HIDs afterwards.

 

I then booted into OS X and opened Parallels. I created a custom VM using my Boot Camp partition. Memory was set to 1024MB (I have 2GB physical) but all other parameters were left at their defaults. I started the machine, loaded Vista (seemed to take a while), and the VM began configuring its drivers and such. Parallels tools installed and then wanted to reboot. I rebooted and I got the transparent Parallels Tools initializing window... and it never went away. I waited for about 30 minutes before deciding that something was clearly wrong. Despite the warning not to do so, I shut down the VM and tried again. This time the initializing window went away after about 45 seconds. All seemed well until the next boot where it got stuck like it did the first time. Per a post I read on the Parallels forum, I booted Vista into Safe Mode, removed Parallels Tools, rebooted, and then installed Parallels Tools using the Parallels menu bar. All seemed well after that.

 

The other goofs I'm seeing is that sometimes Parallels says that it can't find (or maybe use?) the Boot Camp partition. Quitting Parallels and reopening it usually corrects the problem. Weird.

 

Vista runs OK in Parallels but not nearly as well as a native install. With XP I was unable to tell the difference by any seat of the pants measure. Hopefully future builds of Parallels will improve performance.

 

Now if anybody is still reading this, here's a question: say I want to reinstall Vista and recreate my Parallels VM. Will Boot Camp facilitate that? I'm assuming that if I run Boot Camp again it will see the existing Boot Camp partition and allow me to reformat it. Once I do that I think I can just delete the VM from within Parallels and I'm good to go, right?

 

Cheers,

DW

Link to comment
Share on other sites

 Share

×
×
  • Create New...