Jump to content

Boot hangs at BSD root


5 posts in this topic

Recommended Posts

First, I know there's another thread with the same title, however my problem is a bit different.


I installed uphuck's 10.4.9 v1.3 on my notebook:


- Intel Pentium M 1.73 Ghz (SSE2)

- 1 Gb RAM

- GeForce Go 6600 PCI-E

- SATA HD (ICH6 chipset, I guess)

- Marvell Yukon ethernet

- 2915ABG Wireless


The installation went fine (used the universal-3 kernel) and I used the notebook for a few hours yesterday, and that included a few reboots for installing some kexts for my hardware (skge driver, changed keyboard layout, etc). When I got everything to the state I wanted, I turned off the computer and went to bed.


Now, this morning, OS X won't boot anymore. And I haven't done any major modifications on the system which would require a reboot, just casual daily stuff (used Mail, Skype, etc). It was a simple shutdown and boot the next day, and now it won't boot.


While doing a verbose boot, I can see all kexts are being recached. Then the framebuffer kicks in, I get some other messages, then these last two, and the boot hangs (did a line break so the forum won't lose formatting):


Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IDE1@1F,2/AppleIntelPIIXATARoot/CHN0@0/AppleIntelICHxSATA
/ATADeviceNub@0/IOATABlockStorageDriver/IOATABlockStorageDevice/IOBlockStorageDriver/FUJITSU MHT2080BH Media/IOFDi
BSD root: disk0s2, major 14, minor 2


I also tried booting in safe mode and single user mode, to no avail.


The hd's partition layout is the following:


primary 1: NTFS (windows, seldom used)

primary 2: HFS+ (Mac OS X)

primary 3: extended partition

logical 5: ext3 (linux /boot)

logical 6: reiserfs (linux /)

logical 7: linux swap

logical 8: reiserfs (linux /home)


Any ideas? Maybe the kexts re-caching did some unwanted stuff? I'm new to OSx86, so I'm not really sure if my SATA chipset needs custom drivers.



Slightly unrelated: I have already had this issue two days ago, when I first installed OS X on this notebook, but I thought I had messed things up. I'm a linux user (Gentoo), so I had grub installed on the MBR. After OS X was installed, the MBR was overwritten and then I had the Darwin bootloader there (no big deal, but I couldn't boot linux anymore, can Darwin boot linux?). So I booted off a livecd and rewrote the MBR using grub. On the next boot, I couldn't boot OS X anymore (using the makeactive/chainloader directives) and I had the exact same messages as above. I thought I had messed things up so I just reinstalled OS X and had it working again, but this time I didn't touch the MBR and had the same issue again.


I'm actually trying out OS X to see if it covers my needs, so in the future I can buy a real Mac and have it running like it should. I just don't feel like spending money right now on something I'm not sure I'll get used to :(


Please ask if any additional information is needed. Thanks!

Link to comment
Share on other sites

Ok, I got it solved (sorta). Everytime that happens I have to boot the install DVD and write the MBR again (fdisk -u /dev/rdisk0). Then I reboot and OS X loads fine.


The weird part is that after I get OS X booting, I can reboot as many times I wish. However if I shut the notebook down and turn it back on after a few minutes, I get the above issue and need to boot the DVD to write the MBR again. Now that's a real pain.


Any one with magic ideas on how to solve this strange issue? Or maybe an easier way to rewrite the MBR instead of booting the DVD (it's slow)?



Link to comment
Share on other sites

This is becoming a monologue, but it's also funny to see how things are evolving.


The MBR rewriting stuff had nothing to do with the issue; in fact, the boot process hangs if I boot while running on batteries. While running on AC power, the boot process goes fine. The MBR rewriting was just a pseudo-solution, as I usually boot only on batteries, then plug in the AC adapter, so in the next boot it would come up fine as I'd be running on AC then.


So, with this new information, does anyone have any ideas where to start looking for a solution?


PS: I have already tried OSx86 on this machine a while ago (JaS 10.4.6 IIRC) and I didn't had this issue (however had many others which made me drop my OS X tests)

Link to comment
Share on other sites

  • 8 months later...

This happens to me on Leopard too, and it's definitely not just us 2. Let me know if you figure anything out. The one thing that I did notice that we both have in common is that We both have more than one partition, and my setup is the same with NTFS (Vista64) as my first partition and OS X Leopard as my second partition. I think it may have something to do with NTFS, or at least NTFS being first. I can install and boot fine every time off my external USB with only Leopard on it. My external drive is just a test bed so I think I may nuke the external drive and set it up like my internal with NTFS first and HFS+ second and see if the problem starts occurring.

Link to comment
Share on other sites

  • 2 weeks later...

I have what appears to be the same issue, with a single partition installation on my laptop.


Things have been hectic of late, but I recently found that the hardware problems that used to cripple my ability to install a decently working version of OSX on the darn thing had been overcome. Hooooowever. Suddenly my partition decided it didn't want to boot. :/ And now would only boot with the DVD in the tray.


I haven't tried out the fdisk option, but I'll definitely have to get on that.



@gmichels: Did/does your pc actually hang there? Or, if you waited, did it pop up another message. (I ask, because I hang there as well, but, given enough patience, I eventually get an IOPATAfamily kext blocking bus device error message and then the dreaded waiting for root device message.



Link to comment
Share on other sites


  • Create New...