Jump to content

Boot Problems with 10.4.8 - .9 - Failed to load extensions ** - Still Waiting for Root Device


1 post in this topic

Recommended Posts


This is the first message on this forum, but i'm here since Dicember...

First of All sorry for my english, i'm italian, i'll try to write in proper language....


I have a Notebook Hp Dv2268ea, it's a Core2Duo 1,66Ghz, 1Gb Ram, Nvidia GeForce 7200, hdd 160Gb, Intel proWireless 3945, Conexant hdAudio.

First of all i installed mac Osx 10.4.5 with Jas patch (for real I use The Jas DVD), on a External 3.5" Usb HDD - 60 Gb with 2 Partition: 50Gb for the OSX and 10Gb Fat.

All worked great, Iinstalled iLife and FinalCut, my hackintosh worked great, the only things it didn't work was Wireless (Intel Pro Wireless 3945) and Line In on the sound card.

It was good, untill I saw the update 10.4.8 and the iwi drivers for the intel 3945, so I decided to upgrade...

Unfortunally I used the EgWan patch and i didn't repaired permission, so osx wouldn't boot. For real I don't remember the error message, but anyway I re-inizialized the hdd and re-installed the 10.4.5 and then upgraded it to 10.4.7, till yesterday, when i tried to install the 10.4.9 version pathced by EgWan. Here's What i did:

-Backup Copy of the kext extension (7 files from System/library/Extension) to my usb Pen Drive

-Installed the 10.4.9 combo official from Apple's Site (314Mb)

-Force Quit before reboot

-Installed the EgWan patch without customizing the installation packages (34Mb)

-Force Quit again

-Copy the backup-ed extension files in the Extension Dir overwriting the new ones

-Application - Utilities - Disk Utility and restore permission on the 50Gb Usb Hdd





I tried to reboot with -v and i notice that first of all it load the extensions in the first windows (the one with large text characters), but when it change the windows i can see a lot of error messge (yellow text) that says:


"Failed to load extension com.*",


where com.* stands for all extensions in the extension dir, and the line under every error says:


"Kid() undefinded simbols"


followed by all simbols called in the extension, untill it says


"failed to load extensions com.apple.iokit.ionetworkingfamily"


followed by


"couldn't allocate class ()"


and by the infinite loop that says


"Still waiting for root device"


I try to search on internet something about this problem, but i did'n found nothing.

I tryed to boot with:

-v cpus=1 (tryed 0,2, too)

-v boot=disk0s0 (tyed 1, 2 too)

-v -s

-v restorevga


but i got always the same error


I even tried to boot with another usb plug or with installation cd inserted, but always the same result.


Plz, if somebody could help me i'll be thanks.....

If not i'd rather reinstall 10.4.7 that was the newest version that worked for me....


Ps, i'm a student, i use a lot Matlab autocad and nastran, so I need Windows, and moreover the pc it's not mine, so i prefer to install the osx on the external drive, still keeping Winzoz on the internal Hdd... I got another hdd 120gb 3.5", i could use it for the osx, but i got a lot of data there, so if someone think that it could be the reason i'll try to backup data and use the 120gb....


Sorry for my english, i'm Italian....

Tnx everybody.....

Best Regards... Marco...

Link to comment
Share on other sites


  • Create New...