Jump to content

Reinstall Darwin Bootloader?


2 posts in this topic

Recommended Posts

I was dual booting 10.4.8 & XP via the darwin bootloader.


Everything was happy, until I formatted a seperate hard drive using the windows install CD. In the process, it replaced my MBR with NTLDR.


I can boot windows via NTLDR, no prob.


I tried using the chain0 method, with no sucess. Choosing the chain 0 method in the bootloader simply sends me back to the boot loader.


My goal would be to reinstall the darwin bootloader. `fdisk -u /dev/rdisk0` should handle this fine, right? Well, at least from the installer's terminal, it doesn't. I tried it, but NTLDR still stands.


Disk Utility, loaded up from the install CD, shows both my XP & OS X partition's, and verifying my OS X partition suceeds.


I also tried selecting my Mac OS X as the startup disk, via the install CD, but that also is to no effect.


XP: disk0s0

OS X: disk0s1


How can I get into OS X ?


Reformatting is NOT an option.



As it turns out, the darwin boot loader WAS in the MBR, it was just set using a 0 timeout and the NTFS partition was active.

Link to comment
Share on other sites

Could you please let us know how did you resolve it...It sounds like a similar problem that I have. But in my case I first installed grub and it didn't give me any option for osx so I deleted the partition which had linux on it ...but grub stayed on..and now i have a grub loading error..so basically i think i overwrote my existing booting which worked fine and i have not idea how to set it back ...

and i too cannot reformat the whole thing...i have way too much stuff on there.

Link to comment
Share on other sites


  • Create New...