Jump to content

4 posts in this topic

Recommended Posts

Hai there.

 

i have a home network configuration like this

 

INTERNET === XP DESKTOP === MY MAC

 

my xp connects to the internet via LAN cable connected to a modem. i connect my mac to my xp also using LAN cable. my xp machine has two ethernet sockets which are used for the internet and the connection to my mac. i shared the xp internet connection to the mac via ICS. so LAN adapter in xp that connects to the mac is set to 192.168.0.1. i set my mac to acquire address automatically by Using DHCP.

 

xp's firewall was switched off.

 

everything works flawlessly. i can share files between XP and MAC. i can browse through the web with my mac using XP's internet sharing.

 

one day, my younger brother switched on the xp's firewall by accident. this is when the problem came in. my mac's Using DHCP feature now only grabs 169.254.xxx.xxx address. my mac can't browse files in xp desktop, and also the internet's not working. when i manually coded the ip address on my mac, i can browse through my xp machine but still can't get to the internet.

 

i've done these but no improvement:

- switched off the xp firewall

- reinstall osx on my mac

- plug unplug cables on both sides

- switched off ethernet on mac in preferences>network then switched on again by applying Using DHCP

 

i'm not sure now which machine (xp or mac) should i fix. everything was working great for weeks and one switch on the xp's firewall, everything's not working anymore. please advice. thanks

Share this post


Link to post
Share on other sites
Advertisement

done that. but no improvement to the situation.

i've also uninstalled the LAN driver on my xp machine, reset the tcp/ip with netsh command.

i think i should solve the problem by reinstalling xp. but that would be the very last resort. i hope you guys can shed some light here. thanks.

Share this post


Link to post
Share on other sites

okay, problem solved. this thread can be closed now.

 

what i do is this:

 

i switched off my xp machine for about 15 minutes. after i switched it on again, i go to my administrative tools in control panel, select services, and stop the "windows firewall / internet connection sharing" service for about a few minutes. then i start the service again. afterwhich i tried the DHCP settings again on my mac, and voila. no more 169.254.x.x IP address.

 

can't say i totally understand what i did or why i did what i did. i read a lot of stuffs from the web and pick up solutions here and there. tried everything from reinstalling osx, plug unplug cables, switched on off the ethernet, etc. but i'm glad the internet's back now.

 

for the above solution, i'm not sure if switching off the xp machine for abt 15minutes helped. i read somewhere that in some cases using router, the router has to be switched off so that it can "forget" what address it has given to the DHCP client. i learned that ICS in windows has a built in DHCP server called "DHCP Allocator". switching off 15mins probably made that Allocator forget about addresses.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×