Jump to content

DVD Boot and install OK. Safe boot OK. Normal boot panics


3 posts in this topic

Recommended Posts

Ok, I have been crawling the wiki and forums quite a bit trying to get osx installed on my rig. I have downloaded over a dozen dvd images and have only one that boots and installs without errors. It is labeled Jas 10.4.8 AMD and Intel SSE2/SSE3. From what I can tell, it has none of the newer pathches. I have the MD5 checksum for my only working (and all other dvds). I will post those for verification when i go back to work.


My Rig:


Processor: AMD Athlon64 X2 4600+

Motherboard: MSI K9N SLI Platinum (nForce 570)

RAM: 2GB 800 MHz dual channel kingston DDR2

Video: PCI-e Nvidia Geforce 7600 GS 512MB

Storage: PATA 40GB, USB 2.0/Firewire External 250GB


To boot my DVD, the only boot option I pass along is "cpus=2." This gets all the way in to the installer without any errors. USB 2.0 and firewire work, too. I even performed a successful install to the usb2.0 drive. cool. anyway, I have tried installing with all possible combinations. I have tried a bare, basic install. I have tried adding the AMD kexts. I have tried the AMD and Natit Kexts. I have tried installing to the 40GB PATA drive, the usb drive, the ext drive connected via firewire. All produce the same results:


I can boot from the HD in safe mode using these options: cpus=2 -x -v . This is about as far as I can get. I need some help from here. Strangely, the only way I can get any os x install dvd or local installation to boot is to ENABLE all the ACPI features in my BIOS. Disabling them yields kernel panics every time, even with appropriate boot options.


Since I can boot in safe mode, should I try to install correct hardware drivers from a usb stick or something? Should I delete some of the existing drivers?


Any attempt to boot in normal mode yields kernel panics. If the specific kernel panic messages are relevant, I would be glad to take some pics and post them. I'm so close, i can taste it. Please help!




Link to comment
Share on other sites

SMART must be disabled from Bios.

You can edit com.apple.boot.plist to dont have every time to say that you have 2 cpus.

Open it with text edit on desctop and add this lines:


<key>Kernel Flags</key>



Repair permissions and restart after that.


Dont install Nvidia packages on installation, you ll find after that the correct ones.

Link to comment
Share on other sites

Yeah, SMART is disabled in bios.


I also discovered that the 512MB 7600gs isn't supported. On boot, it says it's a 256MB card and the installer/safe-boot loads, so... <shrug> I'll slap a regular PCI card in there and try installing again.


In particular, some ethernet kext causes a kernel panic when booting normally. can i just remove it and all the others i'm not using?

Link to comment
Share on other sites


  • Create New...