Jump to content

Help with Acer Aspire 3020 OSx86 Post Instalation - HFS+ with empty boot sector

1 post in this topic

Recommended Posts

Hello everyone!


I have been trying install OSx86 on my Acer Laptop but I have some problems and need help!


I am at the point where I have installed Mac-OS-X-10.4.7-AMD.Intel-(JaS)-ISO-Repack successfuly in VMware 5.5.3 on a separate partition but it won't boot. I just got a MBR error 3 when trying to boot from HDD.  I examined the boot sector of the osx partition with Acronis Disk Director and I saw that the first 512 bites are zeroes. 


I fixed that:


dd if=/usr/standalone/i386/boot1h of=/dev/rdisk0s3 bs=512 count=1


but it still does not work (disk0s3 is the osx partition). I get to do this when I boot under VMware from the install DVD in single user mode (-s).


The  only new thing is that  Acronis OS Selector now sees Unknown OS but when I 

hoose to boot it I get a blinking cursor and nothing happens.


I tried the chain0 method as well but it also shows a blinking cursor and nothing.


I also tried to use the DVD Darwin boot loader and setting the root device to the partition where I installed the system "boot: rd=disk0s3" but i got a kernel panic and system halt. Here is a picture of the errors:




The system boots under VMware usind the Darwin loader fron the DVD and setting "boot: rd=disk0s3 -x".


Any suggestions on:


1. How to fix the errors and boot not in safe mode

2. How to fix the partiton or Darwin and be able to boot natively


My system description is in my signature!


Thanks for any help!

Link to comment
Share on other sites


  • Create New...