Jump to content

getting a 9800pro working

3 posts in this topic

Recommended Posts

I've installed OSx downloaded the callisto package and started to read the installation guide then I get to part 8 where it say's "Replace my own PCI device ID with yours under the IOPCIMatch key (4150 is mine...)" but I don't see where to find MY IOPCIMatch key. it's reading 0x41501002&0xffffffff at the moment. I tried the computer info and NO cards are listed under PCI and graphics says something like VGA (i'm back in windowsXP now). Can anybody tell me where to get MY IOPCIMatch key thanks.

Link to comment
Share on other sites

You need to get your Vendor and Device ID.


It's a fairly simple process.


If you know how to get to Device Manager, Skip to 4.

1) Goto "Run" and type Sysdm.cpl.

2) Click the "Hardware" Tab.

3) Click Device Manager.

4) Once in Device Manager, goto "Device adapters", right click on your 9800pro and click "Properties"

5) Click on the "Details" tab.

6) In the drop down box select "Hardware IDs"


Your Vendor and Device IDs are listed here.

(For example, mine read PCI\VEN_10DE&DEV_0140&SUBSYS_00000000&REV_A2)

The Vendor number will be the 4 characters after 'VEN_', the Device ID will be the 4 character after 'DEV_'.

You'll need to create a hex string for your kext... and it'll read 0xDeviceIDVendorID (Example: 0x014010DE), This will be the one to replace the one in your IoPCIMatch field.


I'm not 100% sure what &0xffffffff is ... best leave it. In fact just add your string after it. "...&0xffffffff <your string>'


Hope this helps!

Link to comment
Share on other sites

thanks lifeinanalog got it working now. all thats left is SATA on a Asrock 4core-dual-vsta board and the audio(either onboard or my X-fi) I've installed the 775Dual-VSTA 4.1 from steveo but get a message about volume now recognised and still no onboard audio.

Link to comment
Share on other sites


  • Create New...