Jump to content

Independent-persistent not working

2 posts in this topic

Recommended Posts

I'm following this VMWare how-to to do a native install and I'm having a terrible time getting it working. I've tried this a handful of ways, but I can never actually get a partition to format. I've got my hard drive split into 3 partitions:


60GB NTFS for XP

48GB FAT32 (formatted with Partition Magic, 8kb clusters)

131GB NTFS for Windows data stuff.


The 60 and the 48 are both primary partitions. The 131 is all by itself on the extended partition.


I have the JaS 10.4.8 + PPF1 and PPF2 iso from Demonoid. I've thus far been unsuccessful getting the DVD to boot natively, so I figured VMWare would be my best bet.


The how-to does not indicate whether I should set the virtual machine's HDD (Physical) to the whole drive or to just the partition I want for OS X. I've tried it both ways, and I've ALWAYS edited the config file for independent-persistent.


If I tell it just to use my OS X partition, Disk Utility detects a 128GB disk with three partitions (NTFS 60GB, FAT32 48GB, and 20GB NTFS - probably as much of the third partition as possible). None of them successfully mount. None of them successfully format. Nothing. If I tell it to erase the second partition, it tries and then I guess times out trying to mount it. If I try to mount before I try to format, it doesn't successfully mount. Nada, zip, zero.


If I tell it to set the virtual hard drive to be the entire disk, (a) it'll try to boot Windows and (B ) once I tell it to boot from the DVD, Disk Utility behaves exactly as above, except it sees all three partitions correctly. Still can't erase anything, still can't mount anything.


I'm not dumb - at least that's what I tell myself :( - but I have to be missing something. Can anybody help a brother out?


I should note that if I create a virtual drive image, it does successfully install and boot. I've created a 10GB drive with OS X. Is there a way to copy that to the 48GB partition and then make sure it uses the entire available space?


{censored}, I just saw in another thread something about a -vmware flag for Darwin - I imagine I boot from the DVD, hit F8, and then enter that. Is that what I'm missing? Now that I'm at work, I can't do anything to my machine from here...grrrr...guess I'll try it tonight.

Link to comment
Share on other sites

OK that actually made it worse - now I get "Still waiting on root device" though if I don't use -vmware I don't get that. Any ideas?


OK, getting closer - I got rid of "Still waiting for root device" by moving my virtual CD to 0:1.


Still can't get anything to format in Disk Utility, though trying this out is faster now (and I can raise my failure rate quicker) that I don't have to wait on the root device. Bah.


I'm starting to get the impression that for that how-to to work, i need to dedicate an entire hard drive to OS X.

Link to comment
Share on other sites


  • Create New...