Jump to content

Bash 'clear' command gives 'Bus error'


2 posts in this topic

Recommended Posts

When I enter the 'clear' command from the terminal, the systems responds with a 'Bus error'; doesn't matter if I'm root or not. Have tried repairing permissions, etc., but no effect.

 

Also, nslookup just times out, though the network functions are fine in the GUI (no problems with Safari).

 

I'm running Jas 10.4.8 on a Biostar I945G-M7 2.x mobo, which has the Intel 945G/ICH7 chipsets, GMA 950 integrated GPU, and Realtek 8110s Gigabit LAN chip, with an Intel Core 2 Duo 6400 processor. Seagate SATA HDD. NEC/Optiarc IDE DVD drive. Very easy install. No real problems other than the shell.

Link to comment
Share on other sites

  • 2 weeks later...

Hey, I get this error occasionally too. It seems to happen more often when another application doesn't exit as cleanly (e.g. writing to the beginning of the screen buffer w/o clearing the contents - e.g. when I would more likely invoke a 'clear'). However, this may very well be a function of statistical likelihood rather than the direct cause of the problem. I had thought installing fink had solved this, but it doesn't. This happens with both the native console and the X11 rxvt console.

 

Anywho, typing clear again causes an immediate system halt / kernel panic / grey screen of multiligual death, but the crash is inevitable upon encountering such a "bus error".

 

System is a Dell Dimension 5150. 3GB ram, Pentium 820 D dual core. Fink installed and updated to unstable (NOT the cause as the clear bug happened with even greater frequency pre-fink).

 

Hackintosh is great, but the BSD console userspace layer seems neglected! (Home and End keys scroll to the top of the buffer? c'mon)

Link to comment
Share on other sites

 Share

×
×
  • Create New...