Jump to content

7600GT garbled screen - RESOLVED!

4 posts in this topic

Recommended Posts

Hi all!



I've been following discussions from here for a while. 1month ago I got my hands on JaS' 10.4.7 Installer DVD, put up OSX on my machine, and it was quite OK. I upgraded to 10.4.9 JaS Intel SSE3. Then I purchased a ASUS 7600GT. Then troubles begun.

I didn't had QE/CI enabled, my vidcard was not indentified. So I've installed DiaboliK's 10.4.9 Nvidia drivers. Upon reboot, I only had garbled screen with the black cursor, nothing more. Since then I tried many things, like adding device ID in nvidia.kext, but didn't help either.

If I boot in safe mode (-x) display is working OK, even in dual display mode, but without QE/CI.


What do you guys recommend for me to do next?


Here are my system specs:

ASUS P5LD2VM/C mobo, with latest bios, 2Gigs of RAM, P4 915 CPU, SB PCI 128 soundcard, 400G Seagate SATAII HDD, and another 250G Western Digital SATA, which I am running OSX of :hysterical:

The vidcard is a marvellous ASUS 7600GT PCI-Express with 256M of ram, 128 bit, dual DVI model, with SVIDEO TV out. There are NO VGA DSUB connectors.

So any help/idea would be appreciated! Thanks again.

Link to comment
Share on other sites

YIPEEEEE!!! Solved it!


This is how I done it:


- went to safe mode with -x

- installed Natit_uni_1.0.pkg

- restarted, not in safe mode any more

note: I got default res 1024 with no QE/CI and no reschange

- moved NVDANV40Hal.kext, NVDAResman.kext from /System/Library/Extensions_disabled to Extensions

- edited NVDANV40Hal.kext, NVDAResman.kext and GeForce.kext, added my device ID: 0x039110DE

note: for editing

-opened Terminal

-sudo -s, entered password

-cd /System/Library/Extensions

-cd GeForce.kext/Contents

-sudo nano Info.plist

-look for IOPCIMatch

-put in device ID

-CTRL+X, answer Yes to save plist

repeat this for the other kexts


after editing, exit terminal, then repair permissions from Utility/Disk Utility

then restart.

Be careful that the monitor is plugged to the 1st DVI port, just near the SVIDEO out plug. At least this one worked without problems on my ASUS NVIDIA 7600GT


Upon restart I got QE, CI, res change and rotation enabled!!!


Another note: I had installed 10.4.7 Jas image, upon that I upgraded to 10.4.9 Jas Combo update, then I installed Diabolik's 10.4.9 NVIDIA drivers. - At this point I got the garbled screen. After this came the natit driver, and everything was OK!!!

I hope this info helps all the others having problems with 7600GT!!!

Link to comment
Share on other sites


  • Create New...