Jump to content

couldn't find root user


2 posts in this topic

Recommended Posts

Motherboard: Intel D865PERLL Socket 478

CPU: Intel Pentium 4 3.0E Prescott 3.0GHz Socket 478

RAM: CORSAIR XMS 1GB (2 x 512MB) 184-Pin DDR SDRAM DDR 400 (PC 3200)

VID: eVGA GeForce 7800 GS (AGP) 256MB

Distro: 10.4.4 with Maxxuss's 1.0 (8G1165) patch


So the motherboard and CPU are pretty close to perfect for running OSX. The installation went without a hitch. Then I used the terminal in the installer to replace the mach_kernel with the intel patched version, as well as the appleSMBIOS with the patched version.


the shell script seemed to imply that the decrypted files were only needed for SSE2 so I didn't bother with those. after setting GRUB's bootloader to:


title MacOSX

root (hd1,0)

chainloader --force +1


It booted. Though it always boots in verbose mode for some reason, and there's usually quite a few errors (usb, etc) but eventually it spams a bunch of text and then goes to a blue screen with a mouse, but then does nothing - a soft-lock.


I've attached the system log from the boot. Some boots look different than others (probably when i used those options that didn't work) but i most look the same.


Eventually it goes to the soft-lock with a blue screen and a movable cursor, but in the log I've noticed it keeps saying "... memberd[57]: Couldn't find root user. Sleeping and trying again." I've tried using rd=disk0s1 and platform=x86pc with no luck. i've tried using -v so it stays on the command line interface instead of going to a GUI with no luck, but the above message seems to be the main antagonist.


At this point I've tried everything I can think of. Any suggestions?


Link to comment
Share on other sites


  • Create New...