Jump to content

jas 1408 with sse3 ppf1 ppf2 AMD booting problems

2 posts in this topic

Recommended Posts

I just deleted HFS+ partition, where there was deadmoo and made a clean install using AMD jas1408 DVD.

There it seems that I cannot boot up anymore.


I use GRUB for booting.

I tried different methods(I think I tried everything on forums);


1.rootnoverify (hd0,3)


chainloader (hd0,3)+1 ---that works with deadmoo but not with JAS1048

2.chain0 file from NTFS partition ---copied chain0 from DVD to NTFS, which works with deadmoo too but not with JAS1048

3.chain0 file from reiserfs partition. ---copied all boot files from DVD to boot directory

chainloader (hd0,6)/boot/chain0

4.also tried vmware where deadmoo and JAS are mounted and booting up deadmoo partition(image file) then passing

rd=disk1s4 (where JAS is mounted as phsycal partition) to darwin boot loader then I got /sbin/launchd error

if I directly boot to deadmoo it works and I also can see JAS partition mounted RW when deadmoo starts.

I also can mount JAS partition under linux and can read it.

5.dd'ed deadmoo image boot sector to JAS partition. When deadmoo booted up, from terminal dd if=/dev/rdisk0 of=boot_file bs=512 count=1 then copy that file to linux then dd if=boot_file of=/dev/hda4 ..When I boot up and select osx in GRUB, harddisk led keeps blinking as if there is a action but then nothing happens.



--I could boot deadmoo partition with any method up in the list. (directly from grub or chain0 in NTFS or reiserfs)

But JAS1048 doesn't boot with any.

--I can use JAS DVD passing rd=disk0s4 to darwin bootloader then boot JAS partition up easily.

But when I pass this from deadmoo darwin bootloader I got /sbin/launchd error.

--case of chain0 I got 'chain booting error' where it worked flawlessly with deadmoo.



--I started deadmoo in vmware. Using diskutility erased disk1s4(/dev/hda4 or (hd0,3) on real disk). I got a HFS+ partition.

Then started vmware deadmoo as IDE 0:0, phsycal partition (dev/hda4) as IDE 0:1 and a linux boot cd, and booted up with CD. Then from linux terminal I dd'ed hda to hdb4. I got a working physical copy of deadmoo which I could boot in vmware or from grub when the computer started.

So I got a 1:1 copy of deadmoo image in phsycal disk with its booting sector etc...therefore I could boot it up whenever I wanted.

But it looks like JAS DVD has some problems creating that boot sector on /dev/hda4. So when I try to boot it up it cannot find boot sector or other bootfiles in /dev/hda4.

When I boot up to darwin bootloader with JAS DVD and pass rd=disk0s4 it boots it up nicely.



--So what is the difference ???

--How am I not getting /sbin/launchd error from JAS DVD but getting that error from deadmoo's darwin bootloader ?

It seems that when I boot from DVD it reads some essential files from DVD and then passing the control to mach_kernel in /dev/hda4.

--Is there a way to copy those essential files from DVD to physical partition to have 1048 boot up?

--Where does 1048 bootloader mess up and 1041 bootloader doesn't mess up?


PS: I am low on space in my harddisk so I cannot move any partition using partition software.

Hda partition table in MBR:

hd0,0 resiferfs --PRIMARY-- grub is here

hd0,1 ntfs --PRIMARY

hd0,2 EXTENDED --extended

hd0,3 AF/HFS+ --PROMOTED TO PRIMARY from EXTENDED partition --deadmoo doesn't complain anything !



hd0,6 reiserfs main --EXTENDED

hd0,7 fat32


any ideas?

Link to comment
Share on other sites

It is OK now.

After a long work on partitions. Moving, deleting, resizing and creating.

Now JAS 1048 boots up normally.

Moved osx partitions to hd0,2 and reinstalled.

Everything seems fine now.


But anybody knows why 1041 can boot from hd0,3 but 1048 cannot ?

Link to comment
Share on other sites


  • Create New...