Jump to content

Cloning on another HDD


4 posts in this topic

Recommended Posts

Hello, everyone. I have a 100% compatible system here (SSE3 and all the rest), and I installed OSX fine on the slave IDE HDD.


Now, I wanted to have access to more space, so I tried creating another partition with diskpart on the same HDD. That gave me an error with chain0 boot which is what a number of other people are having here (it seems like it gets confused with two AF type partitions on one drive and gives an error).


I have XP on the master drive and the chain0 file is there as well. So I created a 13 GB AF type partition there. Now..I tried using the Disk Utility to restore my files over on it and use "rd=NewPartitionName" during the boot. The system would get stuck at the Apple logo, but the next time I booted the new partition on the master drive was mounted as the main drive while the original one the copy was made from was mounted as another volume.


I tried disconnecting the slave drive so I can finally connect my DVD ROM, but I would get a Chain booting error!


I tried the same thing using carbon copy cloner, but got the same results.. So even if I'm in actuality booting from the master drive, I still need the slave drive plugged to boot....


How do I resolve this? (apart from maybe installing from the DVD directly on the new partition from scratch)


Thanks in advance!

Link to comment
Share on other sites

I have just loaded in the verbose mode with the "rb=NewPartition" (NewPartition, of course, not being the actual name I'm using), and it gets stuck telling me that

"ATA device claims FLUSH CACHE EXT feature support but does not claim Extended LBA feature support".


Just to be sure I checked the BIOS, disabled the SATA controller to only have the PATA devices, and checked that both of the hard drives have the LBA mode on (which isn't the extended one, I believe).


The interesting part is that the master hard drive is 80GB and the slave 40 GB (both by Maxtor). So neither of them even needs the Extended LBA mode. I need to look for a way to disable it..


Still no luck... OSX now will only boot from the 6 GB partition of the slave drive.


EDIT: One more detail. Each drive has 2 NTFS partitions before the HFS+ partition, so the OSX partitions don't take up the whole drive on either of those.


Another EDIT: I have just searched through various Darwin boards and it appears that the Extended LBA warning has nothing to do with the system freeze. On all other machines the system just continues on with booting. But here I get the same "waiting for the root device" error as a lot of other people. That's quite peculiar..

Link to comment
Share on other sites

OK. I got this working :D.


I think the important detail that the guides so far were missing is that you have to make the new bigger partition ACTIVE. In Windows I just used "select partition" and then typing "active".


So I did that, and after that I wouldn't get the chain0 booting error that I would get prior to that. Then I copied everything using Carbon Copy Cloner, and made the partition bootable after writing the MBR on the partition using fdisk (check the Technical FAQ on Wiki if you don't know how).


Then rd=disk0s3, voila! :D.

Link to comment
Share on other sites


  • Create New...