Jump to content

Dell D600 Success


MikeBee
 Share

1 post in this topic

Recommended Posts

Just finished last night installing OSx86 on my Dell D600 laptop. Eventually it worked... Here's my progress:

 

Firstly, I dl'd and unpacked the deadmoo image on my Linux desktop box. Installed vmware 5.5 beta RC2 and got osx86 running ok on that (ie. removed the AppleTPM..... file to disable TPM checks).

 

The I wiped my D600 disk and installed Winblows on a 10gig partition at the start. Then I kicked off Ubuntu live cd (breezy badger) and ran cfdisk to partition the rest of the disk into a 10gig primary and a 20gig logical/extended (for storage).

 

Next I rebooted with the darwin CD and installed that onto the second 10gig partition. Rebooted into Windows and copied the chain0 file from the Darwin CD to c:\ and updated the boot.ini so that I could use the winblows bootloader to get into Darwin. Rebooted and I could boot into Darwin no probs.

 

So I took the HD out of the D600 and (using an adaptor) popped it into the desktop pc. Booted into linux and configured my vmware machine to use the D600 drive as secondary (ie. instead of a CD drive - make sure you remove the CD drive). Booted into OSx86 and the drive popped up. Then I used the drive utility to restore the tiger-x86 drive onto my D600 second partition (where darwin is installed).

 

Strangely the restore got to the end and then popped up with an error 2 message (no such directory I think). But I clicked OK and ran the restore permissions and all worked ok.

 

Shutdown the linux box and popped the D600 drive into the laptop. Booted the laptop and OSx86 ran okay. Logged in and started to get the Dell Truemobile 1300 card working....

 

Found a premade AppleAirPort2.kext on here and copied that in. It loaded fine, but I had to extract it within OSx86. First time round I extracted it in windows before booting to osx. Once the kext had loaded properly and I'd rebooted, the airport utility loaded.

 

Initially, the airport card reported that it was switched off, but in the bios it was set to Alt-F2/Application. I tried setting it to just Application, but that didn't work. Curiously it sprang to life when I turned my built in ethernet on?!? Since then it's been fine.

 

Other things that just worked were the built in sounds and the built in ethernet worked once switched on.

 

Hope this helps for peops running D600s. Overall I'm dead impressed. It boots quicker than winblows (xp), the system feels snappy and the gui is wonderful. Deffo 10/10 and staying on as my main OS. I've migrated from Ubuntu on it's own and initally I've kept winblows as i find that there are some apps i can't do without, but in ubuntu i have the option of vmware or wine. Time to look into ways to ditch windoze altogether!

Link to comment
Share on other sites

 Share

×
×
  • Create New...