Jump to content

Blue Screen with mouse - nothing else


3 posts in this topic

Recommended Posts

I'm sure an answer exists for this, but I'm neither a mac or an avid linux/bsd user... So I'm a littl lost as to where to start looking.


What I get when I boot: If I boot normally or in safe mode, then I get a blue screen with a black mouse pointer, and nothing else. I can move the mouse pointer, so I know thats not frozen.


I have tried booting in verbose mode. Originally I was unable to boot at all, and encountered the "Please restart" message. I then finally started the OS with “Graphics mode”=”1024×768x16@75″ -x and wound up where I am now. With a blue screen, and not much else.


I can boot into single user mode, and get myself dropped at the root prompt, but don't know where to go from here. Although, I suspect this is not the solution, but perhaps a part of it.


I have the deadmoo image and went through the method of Extracting it. Partitioning. dd'ing the image across the partitions. Using the chain0 loader to boot mac os x.



Would there be any advantage in downloading a generic, or patched dvd image and attempting to install off that?


I am also running Windows XP on a seperate partition, and require this to be left alone, untouched, and bootable. So, at the moment, I would prefer to fix deadmoo, since I know my boot options havn't srcewed with XP :)



Mobo: MSI K8n Neo Platinaum. - Nforce 3 with SATA

Processor: AMD Athlon 64 - 3000+ (Deffinately SSE2, possibly SSE3?)

1gb Corsair Ram

2 IDE HDD's. Disk 0 has 3 partitions. Windows on partition 1. Mac on 2.

1 SATA HDD. Single partition.

Radeon x800 graphics card

Keyboard / mouse have been tried with USB and PS/2. Both seem to workm ok



Thanks for any help / ideas guys.

Link to comment
Share on other sites

In single user mode you must delete all kext files who contain ATI string.


the commands to mount your disk and delete the ATI kext files are :


mount -uw / /dev/disk0s1


press enter


cd System/Library/Extensions


press enter


rm ATI*.*


press enter




press enter

Link to comment
Share on other sites

Thankyou for the reply


The steps above were enough to get me on the right track


By typing "mount" I found that /dev/disk0s2 was already mounted at /


From here I was able to cd .. back to /


Next. cd System

cd Library

cd Extensions


From here is was a case of using the rm command, but with a few extra paremeters


rm -d -R ATI*.* Instructing the operating system to remove directories as well as files, and not to prompt me about it.


Then, just restart.


Hope this helps someone else.

Link to comment
Share on other sites


  • Create New...