Jump to content

Enable Sound, Quartz and resolutions for 845G Chipset (Might work for others)


6 posts in this topic

Recommended Posts

Try this for Quartz and Resolutions:


(1) Get the kext files from http://forum.osx86project.org/index.php?sh...=2868&hl=quartz

(2) Delete your existing kext files in the //System/Library/Extensions folder.

(3) Drop the given files in the folder.

(4) Edit the Info.plist in 830.kext:

a. Remove all the strings except 0x25628086 (under IOPCIMatch) under the 830 key.

b. Do not change anything under the 915 key.

(5) Edit the 915.kext file: Edit the existing key under IOPCI to 0x25628086.

(6) Edit the IntegratedGarphics.kext file: Edit the existing key under IOPCI to 0x25628086.

(7) In the terminal do the following:

a. sudo -s (Hit enter then type in your password if you have one)

b. cd //System/Library/Extensions

c. chmod -R 755 AppleIntel*

d. chown -R root:wheel AppleIntel*

(8) Restart


Try this for sound:


(1) Get the AppleAC97Audio.kext file (I'm sure it's somewhere in this forum).

(2) Move the file to the //System/Library/Extensions folder (Delete the file if it exists already before moving)

(3) Do the following in the terminal:

a. sudo -s (Hit enter then enter your password)

b. cd //System/Library/Extensions/AppleAC97Audio.kext/Contents/Plugins/AppleAC97AudioIntelICH.kext/Contents

c. chmod -R 644 Info.plist

d. nano Info.plist

e. Edit all the strings (and delete any extras) under all the IOPCIMatch keys (except that of Nvidia) you can find, to your device ID. You can find your device ID by typing dxdiag in Run in Windows and looking under the sound tab. Mine was 24c5.

f. Ctrl+0

g. Enter

h. Ctrl+x

i. cd ../../

j. chmod -R 755 //System/Library/Extensions/AppleAC97Audio.kext

k. chown -R root:wheel //System/Library/Extensions/AppleAC97Audio.kext

l. kextload AppleAC97AudioIntelICH.kext

m. rm //System/Library/Extensions.kextcache

n. kextcache -k //System/Library/Extensions

(4) Restart


Hope this works for you. Good luck.

Link to comment
Share on other sites

  • 3 weeks later...

I tried it and get boxes all over forcing me into safe mode. I'm going to try again from scratch and use the rm //System/Library/Extensions.kextcache and kextcache -k //System/Library/Extensions to see if that helps (All from safe mode). If it makes a difference or not I'll update my post :-)


[uPDATE] So far, still super sized blocks on my screen. [/uPDATE]


Also in the terminal I did:


~ root# kextload //System/Library/Extensions/AppleIntel830.kext


and got:


kextload: extension /System/Library/Extensions/AppleIntel830.kext is not authentic (check ownership and permissions)


I used the Disk Utility to check and repair permissions, but it says they are all ok.


So then I did:


~ root# kextload -t //System/Library/Extensions/AppleIntel830.kext


and got:


kernel extension //System/Library/Extensions/AppleIntel830.kext has problems:

Validation failures


"Kext has a kernel dependency prior to version 6.0 and CFBundleIdentifier does not match executable's MODULE_NAME" = true


Authentication failures


"File owner/permissions are incorrect" = (









Any ideas? And also note that I did steps j,k,l,m and n from above (except of course with the AppleIntel830.kext)


[Edit FIXED - still no QE]

Edited by BMC6053
Link to comment
Share on other sites

GRRR! My BIOS is set to have 8MB memory yet Darwin says 7MB - regardless I belive I need at least 16MB for QE - Anyone have any idea how to make QE need less VRAM or get more VRAM at boot before I load any kexts related to display? This is driving me crazy - OH! BTW! I'm using OSX 10.4.1 (With 10.4.3 userland)- not sure if upgrading would do anything at all?

Link to comment
Share on other sites

I have only one comment for this...

under 10.4.3 you don't need this patch(both builds) because i945g support is included.

there is also support for sigmatel 9220, so some intel boards are working without problems.

also, CI and QE is working without editing anything.

so I think this is for 10.4.1 ?

Link to comment
Share on other sites

  • 4 years later...

  • Create New...