Jump to content

*FIXED* *Still waiting for root device*


9 posts in this topic

Recommended Posts

Alright guys, to all of you having that problem with the 'Still waiting for boot device' message, here's the answer.


I installed Darwin natively on my IDE drive. It all went OK. So I rebooted and everything worked OK, then I did this


tar xpvf mactelbase.tar -C /


That replaced some of the Darwin system files.. Including some files at /System/Library/Extensions


after I rebooted, I got that annoying message 'still waiting for root device'..


So my conclusion was that my the OSX system was overwriting some bad files, probably the ATA drivers, or something like that.


So what I did was this:


1. mount the OSX hfs volume and moved the extension contents to some directory.

modprobe hfsplus

mount -t hfsplus /dev/hdx1 /mnt/blah

cd /mnt/blah/System/Library/Extensions/

mkdir /home/user/blah

mv  * /home/user/blah


2. Grab the Darwin install CD and copy all the /System/Library/Extensions dir to /mnt/blah/System/Library/Extensions

mount -t iso9660 /dev/hdx /mnt/cdrom

cd /mnt/cdrom/System/Library/Extensions

cp -r * /mnt/blah/System/Library/Extensions


3. Moved the rest of the Extensions that the OSX install is missing (?)

cd /home/user/blah

cp -r * /mnt/blah/System/Library/Extensions


Alright, and that's what I did.. Now OSX actually boots.. there is a problem thought.. I am presented with a Console Login prompt instead of the GUI.


Any ideas?:




Link to comment
Share on other sites

ok ,guys, I had the same problem last night and I was s frustrated, I started playing with IDE Configuration in BIOS and when I changed the IDE Type to P-ATA , then it worked and I booted to OSX. The speed is ok , (even after removing TPM Kext ) OSX doesnt recognize my LAN , graphic card.

I am using Pentium D 2.80 Ghz

Asus p5ld2 - 945 Intel Chipset , SSE3 , SSE2



Hope it would be helpful to somebody.

Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...