Jump to content

JaS 10.4.8 SSE2/3 installs fine, but reg screen is garbled, can't continue


6 posts in this topic

Recommended Posts

I have an HP nc8230 laptop - if you're not familiar with the model, I'll save you the trouble:

Pentium M 1.73GHz, 1GB RAM, 40GB HD, Intel Pro Wireless 2200BG, ATI Mobility Radeon x600 64MB, Soundmax Digital Audio (Analog Devices AD1981B)


So my Lappy is SSE2 ONLY, no SSE3 support here I'm afraid :whistle:


So now you have an idea of what hardware I'm installing on...


I have dl'ed the 10.4.8 SSE2 SSE3 iso, burned it off etc. So far, so good. I burned it with "imgburn" a windows .iso burner, which (in my experience) is the nicest free .iso burner out there... again for windows (gotta qualify these statements, right?)


The DVD boots up - fast. Graphics are fluid - beautiful! Comes up to the initial install screen that says "Welcome to JaS 10.4.8 SSE 2, SSE 3, Intel AMD Install" etc.etc. in about a minute,.


I started out trying to install the bare minimum of what I THOUGHT I need...


System Essentials, Applications, 10.4.8 KTEXTS, 10.4.4 login windows and with the ATI x600 video driver.


So everything installs fabulously, no errors, everything is fine.


The minute I restart, it boots, and goes to the Apple welcome screen - at this point is the first indication that something has gone wrong. It is an 800x600 screen (I believe) but it isn't scaled to fit my screen, instead it is viewed at 100% (in the center of the screen) with some garbled colored blocks below the window. So it goes through the whole welcome thing, then the X loads up...




The screen is completely garbled. I can tell there is a grey X there, but it's split up into 30 or 40 columns, 5 pixels high, spread all over the screen. When I hit esc or enter or tab, I can tell something is happening, but it is so garbled that I can't get through the registration. It's like the video driver doesn't know how to handle the video resolution change. I also have a funny feeling it would work like a charm if it weren't for that friggin registration screen.


So in my desperation, I tried a clean install with the x600 driver and without. I have tried with ALL of the extra extensions (ATI x1000 drivers, azalia audio etc.) and without just to see if it made any difference. It didn't.


I tried commands at boot to force the screen resolution thinking I could prevent it from becoming skewed, but that doesn't work either.


I also have a 10.4.1 build (maxxus I believe) that works like a charm, so I thought "Hey I should be able to upgrade, right?"

Well of course it doesn't, and I did my research on THAT - AFTER I tried upgrading, and it failed lol. (I guess I need 10.4.4 at the minimum right?)


So at that point I got to the grey apple screen, then it locks up.




So I guess basically I'm wondering if there is any way of not going through that registration screen (an old user, which is why I thought upgrade would be the way to go) or if someone else has experienced this same issue and has a better idea on what to do to overcome this.


If this has been posted already, please accept my apologies, but for the life of me I couldn't find anything here on the forums.


(Oh, and just so you know how desperate I am to get this working - I decided to write down all of the options on the 10.4.x install screen thinking I could do it blind - hitting tab, typing, hitting tab, arrow down, enter, tab etc... - but unfortunately the next arrows are selectable with tab, but you can't progress to the next screen by hitting enter. Now THAT is frustrating!!)


Any help that could be provided is greatly appreciated!! :)


P.S. : Now I know this is a lengthy post as it is, but since the illustrious JaS himself is out there on the interweb, and may very well view this very post, I'd like to thank him and all the other fine people out there working so hard to modify and already great product into a much better one ;)


Best Regards,


Edited by mike1979
Link to comment
Share on other sites

OK, So I'm looking more on the forums and the web, I'm not trying to waste anyones time!


I found this link on the forums:



But it sounds differently than the issue I'm having in that the GUI isnt lost until reg is completed, from my understnading... and he's been booted to console mode at this point, neither are happening (yet?) to me, yet it still involves a successful install, restart, and it also involves the registration process.

Though with me its before :unsure:


Unfortunately a clean re-install hasn't helped me either


What I haven't tried is -v or -legacy after the install, on the boot in which reg takes place... Can't hurt to try :)



Edited by mike1979
Link to comment
Share on other sites

OK, so I tried a fresh install again - I installed the base install, the 10.4.8 intel ktext and the 10.4.4 login - installed fine

rebooted with -v -legacy




I tried restarting and, yep came right up.


As an added bonus, even audio was working! So thats really cool.


Now of course I had to screw it up, by trying to install the x600 video driver locatred on the same DVD - now I get a black screen with mouse arrow after the grey apple screen... (sigh)... back to the formus :unsure:

Link to comment
Share on other sites

OK so I undid what I did


(boot -s)

/sbin/mount -uw /

rm - R /system/library/extensions/Callisto* etc. etc.




then built the callsito driver as per instructions on here (tried build 003)


restarted - worked like a charm!!


So now it works at 1280x800 to boot. Then I installed the power management module, also found on here! Sucess!! It even recognizes my two batteries in the menu...


So now I'm off to (hopefully) not break it all by trying the wireless driver... Wish me luck again!


BTW - Has anyone gotten QE or CI to work on an x600?

Link to comment
Share on other sites

I have a HP zd8000, also with the ati x600 mobility card. (device ID 3150) In order for me to get QE and CI working, I had to install 10.4.6 / 10.4.8 JAS but without the "ati mobility support" option. Then install callisto 003 and koverg patch or use z0rz ati script which does the same as the callisto/koverg all in one (again with callisto 003 as the option). Doing that gave me full acceleration, complete with mouse tearing.



A note on the z0rz patch script, for some reason, It didn't complete the device ID in the info.plist within the ATIRadeon9700.kext If the script fails, it might be worth verifying that the device id is complete. I think I ran the script properly, but it is possible that I mistyped something.


Hope that helps :thumbsup_anim:

Link to comment
Share on other sites

Hey thanks 0sxpc,

I have tried that, and yes indeed I can get core image ... I just can't get 1280x800 AND coreimage at the same time. It seems to be an either or proposition. If anyone else out there is able to get correct res & enable coreimage please let me know!! :D

Link to comment
Share on other sites


  • Create New...