Jump to content

Experiences in installing Mac OSx86 on Thinkpads


4 posts in this topic

Recommended Posts

Hey guys,


since I found this amazing forum I decided to install OSx86 an my machine too: Thinkpad R51, 1.6Ghz Pentium-M 725 (Dothan), 768MB RAM, 40GB, SSE2.


This thread is for those (like me) who have (or had) problems in installing OSx86 on their thinkpads. Maybe it's worth to isolate some problems to thinkpad users, since I came across some threads where people described exactly the same or similar problems. (that I've had too (or now have :)).


I want to install OSx86 as a second OS, physically on a second partition after windowsXP.


First I downloaded the myzer patched dvd iso, mac version 10.4.6.

I followed the installation advices from http://forum.insanelymac.com/index.php?sho...mp;hl=iso+patch and partitioned the HDD correctly (hope so).

So, burned the iso to a dvd and tryed to boot from it, after I followed the steps in the tutorial.


But after booting from dvd, the setup loading stops immediately after displaying the gray apple display. What now??!?! Search the forum...


Ok, found out that in -v verbose mode you can get a more detailed error message.

It turns out that the booting process stops after

AppleIntel PIIXPATA:ICH4 ATA/100 (CMD 0x1f0 CRT 0x3f4 IRQ14 BM0x100)...

What now?!?! Search the forum...


Ok, now I try to install OSx86 using VMware.. I got a version of VMware 5.5 and followed instructions from http://forum.insanelymac.com/index.php?showtopic=24490 (Detailed guide to installing ...). It turns out that VMware does not work because directly after the gray apple screen vmware tells me that it does not work on a PAE host ( :hysterical: WHAT!??!?).

What now??? Search the fourm...


I found three possibilities:

- trying to add PAEVM = "TRUE" in my virtual machine config file .vmx. But that does not work!!

- trying to add /PAE in boot.ini to force the start of PAE for windows. That does not work either because after reboot vmware still does not work and the system automatically deletes the /PAE command (even after removing the write protected property of the file).

- or trying to downgrade to vmware 5.0... but the PAE error of vmware still comes up.




Sounds familiar to you??

Is there someone who encountered the same problem or can say what's the next step to check?? It would be very nice cos' this seems to become very frustrating..

Sorry for my english... :)


Thanks to all! Have a nice day...



Link to comment
Share on other sites

I encountered exactly the same with my T41 (same CPU as you). But sadly, I haven't found a solution yet. The deadmoo Image (OSX Ver. 10.4.1) runs, but I can't get any of the Install DVDs to work. I get the same PAE Error after the grey apple comes up.

I've tried all the same Tips you also followed. All with no luck so far. But of course I won't give up and would appreciate every helpful tip.

Link to comment
Share on other sites

You have to go with native, but I can't help you out with that since I used JaS. Of course there you had to copy in the hacked SSE2 kernel manually after install and stuff, but I don't know about your distro.


Your CPU does not have PAE and VMware will fail booting OSX. It may sound odd since OSX runs without it, but this is VMware. You can try all these PAE settings in VMware, but it won't work. It is a lost cause. I would love for someone to corect me on this, though :-)


-- zbob

Link to comment
Share on other sites



@zbob, you were right!! :P

I tried it native and it did!! It works!! This time I tried to boot with JaS 10.4.8 iso.

It's great!! It worked immediately after booting from dvd. No errors... just wonderful!!


Now remains the configuration part.

As I see, the wireless lan card was not recognized. But it seems to me that I came across a thread about installing the wireless lan card. I'll post it here if there's something..


Does someone of you know something about a power management tool like the Battery Maximizer from IBM? I think I can't call IBM and ask for a Mac Version... :whistle:

Does somewhere exist a Mac Version of Notebook Hardware Control??? Or anything else that controls CPU clock? I pray to god...


greetings and thanks to all,



Link to comment
Share on other sites


  • Create New...