Jump to content


1 post in this topic

Recommended Posts

Hi all! Very excited to report this as I’ve seen very few reports of this combo working.

System Specs:

Board - asrock 970a-g/3.1(from 2016)

CPU - amd fx 8350 (2012)

GPU - evga Geforce gt 730 2gb gddr5 (basic use, poor acceleration but works for browsing and watching videos. offically the card isn’t supported)

AUDIO - onboard (alc1150)

RAM - gskill ripjaws x series 16gm(4x4gb) ddr3 1600(pc3 12800, model no. f3-12800cl9q-16gbxl)

SSD's - mac seems to like corsair so i’ve been using some older Force gs, gt and lx 128 to 256gb drives for boot. I also have an older sandisk M.2 2260 drive that works. This asrock board was an early offering for M.2 drives. It has only one slot though.

Wifi/BT - fenvi 1200m. (model no. FV-HB1200). plug and play as mac loves broadcom. it sees the card during setup.

PS - antec ea650 green

msc - using an old asus dvd rw drive that mac seems to like. also using a sandisk 64gb

flashdrive for Opencore.

Used latest Opencore 0.8.9

EFI specs:

Kexts - AppleMCEReporterDisabler, CryptexFixup, Lilu, RealtekRTL881, Sample-USB-Map, VirtualSMC, VoodooHDA, WhateverGreen, XLNCUSBFix.

Drivers - HfsPlusLegacy, OpenRuntime, ResetNvramEntry


Tools - OpenShell

Config.plist - followed the OC quide for amd/bulldozer settings. a few notes: Securebootmodel was set to default, xhiportlimit was false as i mapped out the usb ports. I added DisableRtcChecksum set to true to help with what i think was mac resetting the bios. this is sort of an ongoing project so may have to take further steps.

SMBios - iMac18,2

Bios settings - almost everything had to be disabled for this to work. literally. If anyone has this board and is interested in trying it, let me know and i can give you an exact run down on the settings i used.

sound was a bit of an issue. seems after big sur 11.2.3 VoodooHDA wouldn’t load so had to use the Kext Droplet utility by Chris111 availible on github. theres 2 versions. I used the first one for big sur and monterey. I have yet to try V2. but, anyway, this worked. I had to disable csrutil and csrutil authenticated-root first, then it would install into the L/E folder and on reboot output peripherals appeared. I haven’t tried the mic although the input mic peripherals appear so it probably works.

This is still an ongoing project as i have a polaris 20 gpu on order that should take care of the acceleration issue. but, anyway, it sure was a fun project. Thinking of upgrading to a ryzen 5600g paired with an asrock b550. Saw a few reports of that combo working.

If anyone has an amdFX/970 board combo and would like to attempt this, I would be glad to pass on any info from my experience.


Cheers and happy hackintoshing!

Edited by bobbee12
  • Like 2
Link to comment
Share on other sites


  • Create New...