Jump to content

OpenCore Showing Linux Icons In Boot Menu

5 posts in this topic

Recommended Posts

Hi Everyone

I have really tried hard to sort this issue myself. But after a week I am at a loss.   On my system I have installed Mac OS Catalina, Windows 10, Linux Mint and Garuda Linux ALL 4 OS's work 100% fine

The issue is OpenCore shows 3 Linux icons and a Mac icon in the boot menu. Instead of Mac, Windows and 2 Linux.

I have tried to add Flavour to the Entries and Tools. But all I get is an error on boot saying ocs no schema for flavour at 3 index context entries and ocs no schema for flavour at 1 context tools (these errors may not but typed exact they flash up fast).

If I remove the windows entry under Entries  and set Security > ScanPolicy to 0 from 983299.  I then get the right Windows icon but also get 2 more Linux icons called NONAME and NO_LABEL.

I tried to update OpenCore. Because I thought may be Flavour was not supported in my version. But ended up with a system that wouldn't boot..

Can anyone please help with this? I have attached my EFI

Thanks for taking the time to read this post.



  • Like 1
Link to comment
Share on other sites

@David Boswell

What OpenCore version are you using?

OCS no schema errors are saying that Flavour key is missing in Entries and Tools, you must add a Flavour (String) key in all 3 Entries and in OpenShell.efi Tool.

Flavour must be Windows in the Windows entry (I see Windows disk icon named Windows.icns) and HardDrive in the Linux entries (I see Linux disk icon named HardDrive.icns).

Flavour must be Shell in OpenShell tool (I see OpenShell icon named Shell.icns).

When you set ScanPolicy=0, OpenCore shows ALL bootable partitions, so it's showing 2 EFI partitions (Windows or Linux) as NONAME and NO_LABEL (I guess). Try ScanPolicy=3764995 instead of 983299.

  • Like 2
Link to comment
Share on other sites


Hi, but this is another HW (Coffe-Lake?) Not the one in signature (Haswell) right? in case add it ... thanks

However the OC version was old I updated it and I set the entries in misc ... test from usb, if you use Propertree check that it is up to date

autuneddu you are amazing.. What ever you did it worked perfectly.. Yes this is a coffee-Lake not Haswell.. But I still use my Lenovo as my main system until I get this system finished.. Then i will change my signature..

But that said. Please know I am extremely gratefully both you and miliuco for your help. you have both jumped in and helped with every issue I have had.. So thanks so very much to you both..

  • Like 3
Link to comment
Share on other sites


  • Create New...