Jump to content

KERNEL PANIC - Refusing new kext com.apple.iokit.IO80211Family


4 posts in this topic

Recommended Posts

Hello all,


Been around for a while but new to the OpenCore world.


I successfully installed OpenCore 0.7.7 and upgraded from Mojave to Catalina on my Dell XPS2720.


This is an old Haswell AIO system. It was a perfect vanilla Mac under Mojave.

Under Catalina it was equally perfect so long as my SMBIOS platform was iMac14,2.

So, I went ahead and upgraded to Big Sur, changing the platform to iMac14,4.


It seems very solid so far aside from one little problem.


It will Kernel Panic on boot if I try to inject my old Mojave IO80211Family.kext from OC/kexts.

I needed to remove this kext from the config in order to complete this upgrade.

I run with an old Atheros AR9462 WiFi card and so use the Mojave IO80211Family.kext with a

High Sierra AirportAtheros40.kext Plugin and this has worked just fine under 10.14 & 10.15.


I  suppose that I could try to move this stuff into LE but would definitely like to avoid that.


So, I put this question out there.


Is there some config adjustment that I can make to help this kext replacement to happen ?


Thanks in advance,



Link to comment
Share on other sites


That method wont work anymore. No solution for Bigsur and above.


I appreciate the quick response but would you mind expanding just a bit on this ?


Exactly what won't work ?  No solution for what exactly ?

The part about injecting a kext faked with a higher version number intended to replace an existing stock kext ?


Or rolling back to kexts from previous MacOS releases regardless of the technique ?


Is this particular problem because the existing stock kext is already present in the prebuilt kextcache ?


Where can I find some discussion about this ?


Would it be possible to fall back to the old methodology of dropping the replacement kext into LE thereby

invoking the cache to rebuild with the kext replaced ? Not as clean but, if it works ...


And why does this result in a KP ?


I've seen cases in the past where kext replacements were refused but never accompanied by a kernel panic.


I'm in the process of cloning my boot drive before I start permission gaming the root partition.


One way or the other, I'm gonna find out.






Edited by bisk
Link to comment
Share on other sites


  • Create New...