Jump to content

Problems installing Catalina 10.15.7 with OpenCore Dorthonia guide

Gabriel Fassani

4 posts in this topic

Recommended Posts

Hello!, i'm new to hackintosh and trying to build a hack with this specs:
processor: i3 10105
mobo: gigabyte h410 s2h v2
gfx: uhd 630
guide used: Dorthonia
i had some issues with making the installer on windows (com.apple.recovery.boot method), it gave me a "No Name" item in the place of the installer which would always give me a "could not read \EFI\" error. So i then used the mac of a friend to make the installer, same guide just different way of getting the os, this time i do get a "install macOS Catalina (External)" option, but when i use it i get the following

[EB] "LD:LF] FIO: O, DIR: 1, P: (null string>, DP: 1

[EBI 'B:SBS) SZ: 621112

[EB #B:SHA] 4f3bba9614aa0dbae 1943ab55b83beac7e278986

[EBI WLWLFNV) Err(OxE) O GV wake-fallure




[EB] *LD:LKC) BPDK -> (System\Library\Pralinkedkernels\prel Inkedkernel.development >

[EB] 'LD:0FS) Err(OxE) OPEN (System Library\\Pralinkedkernels (pralink@dkørnel development >

[EBILD:LKCBPDK, IR -> (System Library\Prelinkedkernels\prel Inkødkørnel)

[EBİ'LD:LKC) } Err(0x1)

[EB #WL16) Ox01 Ox01 22 OX01

[EBI ASTOPI '8:MN) Err (Ox1) LD:LKC 

[EBI#WL(7) Ox01 Ox03 22 OX01

Exiting eftboot...

[EBI*WL 😎 Ox01 Ox03 22 OX01

I already checked many times the BIOS Settings, there is only two settings i cant find not even in the manual "Execute Disable Bit" and "Thunderbolt", all of the rest are correctly set. I've also tried some config.plist suggestion fixes regarding the following quirks:


RebuildAppleMemoryMap -> False
SetupVirtualMap -> True

FIX 2 for this one i tried both configurations

If your firmware supports MATs(2018+ firmwares):
EnableWriteUnprotector -> False
RebuildAppleMemoryMap -> True
SyncRuntimePermissions -> True
For older firmwares:
EnableWriteUnprotector -> True
RebuildAppleMemoryMap -> False
SyncRuntimePermissions -> False

DevirtualizeMmio -> False


Add UsbInjectAll.kext
i also added it to the config.plist file



i had found that it can solve the issue, in my case it did not, i know it's supposed to be for Navi Gfx cards, but hey it was worth a try

Other than that, i've checked many times my config.plist in contrast with the settings for comet lake in the guide and i can't find any mistakes, the plist is attached, also for the files used in my efi configuration:


  USBInjectAll (added this one later for attempting to fix the issue, didn't work)
 *this last three files came in some of the kext packages, they have no file extension but the folder pointed to Tools, so i put them in place, yet, i've also tried removing them, same results:

Hope someone can shed some light on this, as i can't figure out the issue based on the error output and there arn't too many more options in the internet

Note: i've already tried with opencore 0.6.9 / 0.7.2 / 0.7.3 with same results
Note 2: BIOS settings, as per the guide
*Fast Boot
*Secure Boot
*Serial/COM Port
*Parallel Port
*VT-d (can be enabled if you set DisableIoMapper to YES) i disabled it
*Thunderbolt(For initial install, as Thunderbolt can cause issues if not setup correctly)
There is no thunderbolt support in this mobo
*Intel SGX
*Intel Platform Trust
*CFG Lock (MSR 0xE2 write protection)(This must be off, if you can't find the option then enable AppleXcpmCfgLock under Kernel -> Quirks. Your hack will not boot with CFG-Lock enabled)i disabled it
*Above 4G decoding
**2020+ BIOS Notes: When enabling Above4G, Resizable BAR Support may become an available on some Z490 and newer motherboards. Please ensure this is Disabled instead of set to Auto. in my mobo Rezisable BAR is an option and it's currently disabled
*Execute Disable Bit There is no such option for my mobo, checked even on manual
*EHCI/XHCI Hand-off
*OS type: Windows 8.1/10 UEFI Mode
*DVMT Pre-Allocated(iGPU Memory): 64MB



Logs txt file and config.plist:




Thanks in advance!

Edited by Gabriel Fassani
remove dots in the end
Link to comment
Share on other sites

I'm a bit confused.  Just to clarify: Has your hackintosh been working before?  Or this is the first install?

The reason I'm asking is: There are problems with ProperTree with OC 0.7.3.  So you are best trying with 0.7.2 to get it working

I'm not sure if you were on Catalina before, trying to update to Big Sur, there have been a few changes in Big Sur making it more tricky to install

- you may try with installing Catalina first, then trying to upgrade to Big Sur

- The main difficulty with Big Sur update was the USB mapping.  USB-Inject-All.kext doesn't work on the newer Big Sur versions.  So you'll need to map your USB ports

- so you may want to install Catalina first with USBinjectAll.kext, once it is working on Catalina, try to get the USB Mapping working on Catalina, before trying on Big Sur.

- - The main difficulties with USB Mapping: Hackintool for some reason doesn't show the USB ports correctly, The USBMap tool is more accurate.  You may want to find out the USB port with USBMap tool, then use Hackintool to generate your kext.  When using Hackintool, just ignore the labels that are different from USBMap, and just follow USBMap namings.

Edited by slam
Link to comment
Share on other sites

  • 1 month later...

Hello!, i'm sorry for the late reply, i was out for two weeks after posting this for personal reasons and when i got back i got it solved in the most silly way, it looks like the problem was that the usb drive was faulty, causing some files to be missing and so giving crazy errors like this. Once changed i just followed the guide and got it to work.
But to answer to the questions and for future reference, this was a first install attempt.

Also thank you very much for the recommendations on the installation, i've indeed installed Catalina mostly because after reading the guide i found it was the most suitable option for this rig, but i'll have your word in mind for if later i want to upgrade to Big Sur, also i'll try to do the USB mapping just because it's supposed to be more stable that way, although i've not found any problems in catalina yet even without the usb inject kext.


Thank you so much for the reply again and i'm very sorry tat i've not answered until now, that was rude from me.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...