Jump to content

HD4600 intermittent QE/CI (Big Sur)


Haggis
 Share

3 posts in this topic

Recommended Posts

I've set up my first Hackintosh (HP EliteDesk 600 G1 SFF i5-4590) with OpenCore, and it's gone really well, except that the HD4600 only sporadically has Quartz Extreme (QE/CI). When I restart, it seems random to me as to whether it will be good or not. When it's bad, the dock is not transparent etc & Hackintool reports the following:

 

* VDA Decoder: Decoder Failed

 

* Quartz Extreme (QE/CI) No

* Metal Supported No

* Metal Default Device No

* Metal Low Power No

 

Does anyone have any suggestions for what could cause this unpredictable behaviour? `config.plist` attached.

config.plist

Link to comment
Share on other sites

I checked the properties you inject and the SMBIOS you use. All seems Ok with your choice of iMac14,4. With regards to iGPU properties injection, you inject the correct desktop Azul framebuffer and there's no need to inject iGPU id 0x0412 given that it's the native id of the HD4600 iGPU fitted to your i5-4590 CPU; however, I don't believe you need to patch stolenmem and fbmem on Haswell platforms.

HD4600-PropInj.jpg

 

I sure never did so and still don't on my HD4400 Hackintosh laptop so I would suggest you experiment without those 2 x patches. To me, those were only required with Broadwell platforms and later. What is sometimes required, on the other hand, is the cursormem patch that sets it to 9MB in order to fix glitchy graphics/cursor lag.

framebuffer-cursormem        00009000        DATA

 

On the kexts front, I saw the list you inject and it does contain Lilu + WhateverGreen so maybe just check that you use the latest versions.

Link to comment
Share on other sites

Hi — thanks so much for your time, it's awesome having someone so knowledgeable examining my config.plist :)

 

I removed stolenmem and fbmem as suggested. Then I tested it with a series of restarts:

 

* after the first restart nothing improved

* I restarted a second time and cleared NVram this time (from the OC boot menu) and this time everything worked perfectly

* I restarted a third time to see if it was still good and unfortunately it had reverted to the bad state

 

So overall the changes don't appear to have helped. As previously, if I restart enough times (3 or 4 usually) without changing anything at all, I eventually get a reboot where the QE/acceleration is working perfectly.

 

Both Lilu (1.5.5) and WhateverGreen (1.5.2) are at the latest versions.

 

I also tried adding "framebuffer-cursormem 00009000" but then the HP wouldn't boot successfully. Eventually I just reverted the config.plist.

 

I'm wondering if perhaps my config is fine, but if something else could be the cause. eg would a flat CMOS battery have any chance of causing this?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...