Jump to content

Need EFI to install High Sierra 10.13 on a Sony all I one


11 posts in this topic

Recommended Posts

On 9/3/2021 at 3:46 PM, Hervé said:

Could be most useful to post the system's specs...

What do you mean. All the information is at the bottom of the post


Sorry but if you meant the system in signature, that was not clear at all, at least to me.

 

Anyway, given that you run Sierra 10.12.6 on it, you can simply upgrade to High Sierra with the same EFI. Just update your add-on kexts to latest versions as precaution (eg: Lilu, WhateverGreen, etc.) before you proceed.


Bear in mind that High Sierra will convert your partition from HFS+ to APFS by default. If you don’t want that, apply the necessary option during the upgrade/installation.

 

NB: You may just use there Reply box at he bottom of each page, quoting messages to post a direct reply is not necessary. If you want to draw attention to someone, use the @<pseudo> facility.


Thanks for the reply 

 

I tried an update in the past but I think it was with another version of macOS but I’ll try it 

 

I was really looking to install High Sierra on another drive, but I guess I can install Sierra on that other drive and then upgrade it

 

once again, thank you 


just tried to upgrade my system from Sierra to High Sierra. Got this message. "To install macOS High Sierra, a firmware update is required." Attached is a screen shot.  Any assistance on what I should do next would be appreciated.

 

 

Sreen shot.jpeg


Open your config in Clover Configurator, go to SMBIOS and select "Update Firmware only" and then select a model closest to your CPU from the dropdown menu. Save Config and reboot and try updating macOS again.

 

Otherwise Upload your current EFI please. Is it a Notebook?

 

 

2037366425_Bildschirmfoto2021-09-06um20_13_30.thumb.png.bc571269023a7ecd5c79cd81b3f1f3af.png

Edited by 5T33Z0

I'm using Clover Configurator version 5.18.3.0, as you can see from attached picture I don't have the "Update Firmware Only" option.

 

 

Clover Configurator.jpeg


Sorry but I do get the option and exact same view as posted by 5TZZ30 if I open CC v5.18.3.0 without a config. I'd check the version you're running or re-install but I don't believe you're running that same version at all...


@dsalsa Could be  a bug

  • Create a new, empty empty file
  • Open the Dropdown menu right next to the missing text (should still work)
  • Select the same mac model you are using in your config
  • Copy the newly generated data from the following Sesctions and their fields to your config: Bios, Board, Firmware
  • Save, Reboot, try installing HS again.

 

Edited by 5T33Z0

 Share

×
×
  • Create New...