Jump to content

[SOLVED] Ethernet en1 and wifi en0 after installing Monterey Beta 5


2 posts in this topic

Recommended Posts

After installing Monterey Beta 5 in 2 different ways, one update and one from scratch, the BSD name of the network interfaces has changed, Ethernet as en1 and wifi as en0. These interfaces have had the right BSD name in this hack from High Sierra, it is the first time this happens.


I have tried the usual methods:

  • Delete and recreate interfaces in network preferences
  • Modify and delete Locations
  • Delete NetworkInterfaces.plist and Preferences.plist in /Library/Preferences/SystemConfiguration.

Unsuccessfully.


The only thing I have not tried is to open the PC box and temporarily remove the wifi PCIe FENVI card.


I have been able to solve it with the old method of @RehabMan NullEthernet.kext + SSDT-RMNE.aml. This method was intended for users who did not have an Ethernet adapter (or the one they had did not work on macOS) and needed to create a fake one to be able to connect with Apple services. But it has helped me to have the Ethernet adapter as en0:

  • Install NullEthernet.kext + SSDT-RMNE.aml in OpenCore
  • Delete NetworkInterfaces.plist and Preferences.plist
  • After reboot, Ethernet adapter is shown as en0 and fake Ethernet adapter is shown as en1 with wifi as en2
  • Delete the network interface of the fake Ethernet
  • Remove NullEthernet.kext + SSDT-RMNE.aml from OpenCore
  • Reboot

The system seems to work well, with Ethernet as en0, but wifi has remained as en2 although it also seems to work well.

 

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

  • miliuco changed the title to [SOLVED] Ethernet en1 and wifi en0 after installing Monterey Beta 5

Hi Bro - I too fell into this problem in the past on my GA-EX58-UDR3 board with Ethernet registering as en1 and wifi as en0. This caused a problem as I could not log into the App Store and some of the Apple Services. Short of a reinstall I could not switch the settings around to make Ethernet as en0, but if it is not causing you a problem then I guess it's ok. It is not an unusual problem but not so much these days, it use to happen quite frequently in the early days. If I remember clearly there are a few posts about this problem on the other side :wink_anim::wink_anim: if you dig deep enough.

  • Like 2
Link to comment
Share on other sites

 Share

×
×
  • Create New...