Jump to content
23 posts in this topic

Recommended Posts

Leaving picker to "builtin", and picker variant to 17leaves me with no os to pick?

see image could anyone help. This is only loading of a usb flash as i currently 

run opencore 69 without issue, using builtin. I have tried the space bar to see if it would toggle any options but as you can see no big sur or montrey±

IMG_20210614_124126.jpeg

Edited by fuzzylogic

If you've updated to OC 0.7.0 or 0.7.1, I think you need to update the config.plist with the New Flavor options also while you're at it, you should also update the Resources Folder which you can find here -https://github.com/acidanthera/OcBinaryData - for the latest version. Good luck

  • Like 1
  • Thanks 1

Hi and thanks for your suggestion, however it did not change the screen as above, I think with picker built in it should have all the resources it needs hence built in

i did try and load up the icons pack and updated the drivers but as above! I will keep trying

Herve is correct - looking at your readout, you have too many things selected in your config. plist also the Validate reading is showing errors (see my attached readout).

Screen Shot 2021-06-16 at 13.46.19.png

  • Like 1

1040253301_Screenshot2021-06-16at14_19_04.png.42cff953b8041da0627c138894b50d11.png

have tried as suggested, the  red error for some strange reason is to do with the fact that i have picker set to builtin.

my os does boot i am just trying via a usb flash with opencore 071

my current opencore is 069 which works fine even with builtin

I will keep chipping away at it i always try via a usb flash any new versions of opencore that way i still retain a bootable os

thankyou for your help much appreciated

@fuzzylogic Hi - If you click on the 'red error' it will tell you exactly what is missing or wrong. You need to click on the 'Upgrade OC main Program' Icon to correct the errors and then save the alterations, reboot and clean NVRAM. (See attached).

Spoiler

158709629_ScreenShot2021-06-16at17_40_41.thumb.png.1a28bfc656ab11a46f11b617fa35d19f.png

 

  • Like 1

it would seem some of the errors are actually opencore builds here is the latest information from opencore this is the latest commit so opencore 071-06-911527514_Screenshot2021-06-18at20_54_15.png.19b4af1f615bbb9d5474e51afe3d4157.png

Do you have all OpenCore related files from the same build? I mean Drivers - Tools folders (and their content) and OpenCore.efi.

yes, i just transfere over my config file to the new efi folder on my usb flash drive and try and boot from it. I have been using opencore for a long time so i suspect there are too many changes thus causing issues between the various motherboards, although my motherborad is a z390 the asrock boards tend to have their own quirks, basically i look at my old working config plist and compare it, so my working config is for opencore 069 which boots fine so i check that off the latest commit. In the boot menu it shows the icons but they are efi which to me suggests that it is looking internally, I may try looking at picker again

 

3 minutes ago, fuzzylogic said:

yes, i just transfere over my config file to the new efi folder on my usb flash drive and try and boot from it. I have been using opencore for a long time so i suspect there are too many changes thus causing issues between the various motherboards, although my motherborad is a z390 the asrock boards tend to have their own quirks, basically i look at my old working config plist and compare it, so my working config is for opencore 069 which boots fine so i check that off the latest commit. In the boot menu it shows the icons but they are efi which to me suggests that it is looking internally, I may try looking at picker again

 

Upload your zipped EFI folder here.

3 minutes ago, fuzzylogic said:

i cannot find a zip archiver that would permit me file size too big to upload,

Mount your EFI partition (the one with the problematic EFI folder > Empty trash.

Copy your EFI elsewhere. Remove this folder: Resources > Audio. Zip it. Size?

@fuzzylogic - Hi the Resources folder contains no files they are all empty (is that intentional?), you need to download the lates files Resources files from here -  https://github.com/acidanthera/OcBinaryData - and replace the one found with yours. You may have to delete some of the language files in the Audio Folder for your own as it maybe too large for the EFI Partition in it's entirety. Here I have downloaded it for you but like I said you will need to remove the other languages in the Audio Folder for your own.

Resources.zip

7 hours ago, eSaF said:

@fuzzylogic - Hi the Resources folder contains no files they are all empty (is that intentional?), you need to download the lates files Resources files from here -  https://github.com/acidanthera/OcBinaryData - and replace the one found with yours. You may have to delete some of the language files in the Audio Folder for your own as it maybe too large for the EFI Partition in it's entirety. Here I have downloaded it for you but like I said you will need to remove the other languages in the Audio Folder for your own...

I asked @fuzzylogic to remove Resources/Audio to decrease the size of the EFI folder, perhaps it has removed all in Resources.

 

8 hours ago, fuzzylogic said:

EFI.7z removed all audio and labels in resources folder, thank you for helping

Ok, I'll see and comment.

 

Edited by miliuco

to reduce file size resources folder contents were removed remember that this efi is the latest commit from opencore

you could try builtin as the boot option and also remember that most programs like oc auxiallary tools will throw an error due to it not supporting commits above 070 the commit in the efi is 071

@fuzzylogic

Here I upload your EFI.

I have added Acidanthera / GoldenGate theme in Resources / Image folder, it is the default theme when PickerVariant = Default.
I have set PickerAttributes = 144 for the new Flavour system implemented in 0.7.0 to work.
I have made minor changes to config.plist.
I booted from USB with this EFI and the OpenCanopy picker shows perfectly (screenshot attached).
Try yourself and comment if it also works well.

 

EFI-0.7.1.zip

 

29 minutes ago, fuzzylogic said:

to reduce file size resources folder contents were removed remember that this efi is the latest commit from opencore

you could try builtin as the boot option and also remember that most programs like oc auxiallary tools will throw an error due to it not supporting commits above 070 the commit in the efi is 071

In the EFI I've uploaded, PickerMode = External, Builtin shows the picker in text mode.

Default validation tool from OpenCore developers (ocvalidate) throws no errors at all.

 

 

Edited by miliuco
×
×
  • Create New...