Jump to content

Hello - Big sur working bar some ethernet issues.


2 posts in this topic

Recommended Posts

Posted (edited)

Hi,

 

just joined after trying out opencore with a new install of big sur on a separate SSD. Got some minor issues that need sorting out.

 

I have a working hackintosh z97-A motherboard, 4790K, saphire pulse 580 working fine in mojave using clover.

 

Decided to make the jump straight to Big Sur. Also having read around a lot it seemed that opencore was way to go.

 

I got a new SSD, used macbook to install big sur on it - reason is that I read that it's not possible to directly install big sur on motherboard without modifying the bios firmware.

 

Then created installed opencore using the guide. Had a few issues getting it to start but then found another EFI here 

 

That gave me something to start with. After a bit of fiddling I got it to launch. Then did some USB mapping of my own to get USB ports to work. Then did some more fiddling to get to latest version of opencore.

 

My problem now is everything works properly except ethernet.

 

I started out with IntelMausi as described in the opencore guide. This lead mac to say "Self assigned IP" so wouldn't connect.

 

I restarted back to mojave and checked existing build and it uses appleintele1000e. So I tried that instead(of course doing propertree clean snapshop between each change).

 

This time ethernet worked, but after sleep it stops working, I can get it going again by using ifconfig en0 down and ifconfig en0 up in terminal.

 

I then read some more and it seemed that maybe intelmausiethernet was the thing to use so I just downloaded it and tried it.

 

This time mac said ethernet was connected, I got IP from router, everything in network settings looked like it should be working but no internet connection at all, can't even access the router via browser.

 

Any suggestions what to try next ?

 

Thanks.

 

 

EDIT: I just restarted again and at first the ethernet said not connected,(still using IntelMausiEthernet) about 30 seconds later the ethernet tab in system preferences switched over to green saying connected, but still no actual internet connection.

 

 

EDIT 2: I was looking at the ifconfig results in the terminal and noticed it noticed it said 1000baseT. I know my computer doesn't have gigabit ethernet. So I went into network prefs, ethernet, advanced, hardware and it said 1000baseT when set to automatic. I switched to manual and selected 10baseT.UTP, hit apply and internet connection is up and working. No idea why it defaulted to 1000baseT. EDIT 2A: Actually just checked and motherboard should have gigabit ethernet. So something is still horribly wrong

Edited by Smink
  • Smink changed the title to Hello - Big sur working bar some ethernet issues.

Hi,

 

well the problem has been resolved though quite how I'm not sure.

 

I booted into windows which I have on a separate ssd and the ethernet wasn't working. I tried reinstalling the drivers, and even went as far as doing a complete clean install of windows - I don't use it for anything apart from a couple of games. Still no joy with ethernet. I then saw a thread somewhere where they suggested powering down completely and  unplugging from mains for 5 mins then restarting.

 

I did that and ethernet was working again in windows.

 

Now when I use intelmausi in my opencore efi ethernet works fine.

 

Don't know what happened but if all else fails try turning it off(completely) and then turning it on again.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...