Jump to content

[Solved] Unable to map USB ports - some USB 2.0 ports are not recognized


6 posts in this topic

Recommended Posts

Posted (edited)

Asus Z87M-PLUS, macOS 11.3.1, vanilla system set up with OpenCore 0.6.9.

 

Everything works fine - the system is stable, sleep, pm, sound, dGPU, iGPU - everything works well except for USB ports. Some USB 2.0 ports are not recognized. 

 

I completed the System Preparation section from Dortania Guide:

  • Applied devices rename (I only needed EHC1 to EH01 patch) with ACPI patch
  • Installed UsbInjectAll kext
  • Enabled XhciPortLimit

 

USBMap doesn't report any issues:

261646803_Zrzutekranu2021-05-16o12_42_38.png.6e75545f414a22d681a9562bb29998c6.png

 

But when I start mapping USB ports then I have a problem with some USB 2.0 ports:

  • All USB 3.0 ports are recognized
  • The majority of USB 2.0 ports is recognized
  • Remaining USB 2.0 ports are not recognized.

 

There's nothing wrong with the mobo itself because these ports work well under Windows, I can even boot Clover/OpenCore when I plug-in a USB 2.0 bootable pendrive to these ports which are not recognized under macos. The problem is only with macOS. USBmap/Hackintool/Finder doesn't see devices plugged in to these ports.

 

Here's my OC config:

 

config.plist

 

 

 

Edited by wujek_bogdan
Posted (edited)

Could you elaborate a bit more?

  • If I do that do I still need EHC1 to EH01 rename patch?
  • Will I still need UsbInjectAll?
  • Will I still need XhciPortLimit

 

If possible I would rather prefer to map ports rather than installing some additional kexts. This seems to be a cleaner solutions.

Edited by wujek_bogdan

Renaming EHCx to EH0x is a common and standard near-universal requirement since Catalina (though some Hacks still work without). So your question is kinda irrelevant.

As I said, those kexts would just allow you to split USB2 from USB3 and would simply come as an addendum to your existing setup. Whether you want to experiment with them is entirely up to you.

  • Like 1
Posted (edited)

I have a similar issue in 11.4. 

 

With my Catalina-created USBkext: Mapping is broken, only 1 SS port is recognized, and the rest are HS - though they do work at slow speeds

 

Without the kext, enabling XHCIportmapping in OC: No HS (USB2) ports are ever detected no matter what device I put in, but all SS ports work and can be mapped in the tool 

 

Used the latest OC 0.6.9 and the latest USBMap for my testing. Also cleared NVRAM and misc. Did not use USBInjectAll. 

 

May just be buggy cause of beta status so decided to not fuss more than I already have! 

Edited by nazrm
Posted (edited)

I managed to map my ports - in a hacky way, but I did it. I noticed that having XhciPortLimit set to true cause some USB 2.0 ports not to be recognized but all USB 3.0 to be fine, but having it set to false results in the opposite: some USB 3.0 ports are not recognized, but all USB 2.0 ports work fine.

 

So, I set it to true, mapped all USB 3.0 ports, restarted the PC, set it to false and mapped all USB 2.0 ports. Thanks to this I got all ports mapped. Then I generated USBMap.kext and removed USBInjectAll.kext.

 

Everything works fine now.

Edited by wujek_bogdan
  • Like 4
  • wujek_bogdan changed the title to [Solved] Unable to map USB ports - some USB 2.0 ports are not recognized
×
×
  • Create New...