Jump to content

Having trouble getting USB to work


5 posts in this topic

Recommended Posts

Hi all,


I am trying to install OSX 10.15 (Catalina).

I am trying to build my first hackingtosh and I am running into some issues with USB not working.

Everything boots fine but during the process of the OSX installer loading the USB devices go off and won't turn back on.


I tried:

 

  • Adding USBInjectAll.kext
  • Enabling/Disabling XHCI handoff in the BIOS
  • XhciPortLimit to TRUE
  • Adding SSDT-RHUB.aml

 

My specs:

  • Intel i7-10700k
  • 16 GB DDR 3200 (Corsair Vengeance LED)
  • Asrock H570M-ITX
  • MSI Radeon 580 OC Armor
  • Samsung 980 NVMe SSD

 

My SSDTs (prebuilt):

  • SSDT-AWAC.aml
  • SSDT-EC-USBX-DESKTOP.aml
  • SSDT-PLUG-DRTNIA.aml

 

My Kexts:

  • AppleALC.kext
  • IntelBluetoothFirmware.kext
  • IntelBluetoothInjector.kext
  • Lilu.kext
  • LucyRTL8125Ethernet.kext
  • NightShiftEnabler.kext
  • NVMeFix.kext
  • SMCProcessor.kext
  • SMCSuperIO.kext
  • USBInjectAll.kext
  • VirtualSMC.kext
  • WhateverGreen.kext


And my config.plist:

https://gist.github.com/thecodeassassin/5674f30bd01b501802ed9071a5a91a67

I'd appreciate any help, thanks all.

Edited by thecodeassassin

hey thanks for the reply!


I solved it by switching to a Z490 board, I couldn't get any Z570 board to work :( Swapped out the motherboard at least 3 times.

 

The motherboard is a bit more expensive, but still much cheaper than a Mac Pro xD

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...