Jump to content

Lenovo Legion Y740 on OpenCore 0.6.8 unable to get to installer


9 posts in this topic

Recommended Posts

I have been trying to fix this error for the past day with no success, I have followed dortania guide for coffee lake plus laptops.

I have tried editing the config file multiple times every time from scratch. downloaded all the relevant files and still can't boot to installer i am using the latest OpenCorePkg 0.6.8.

I have also disabled secure boot in the bios settings and changed the SATA mode to AHCI.

 

P.S. yesterday i have been also getting the pci configuration end error.

 

Here's a link to my EFI folder:

https://www.dropbox.com/sh/a2bxgk7y5rh77li/AADsxdKwJRtwghFW3aJBdfp3a?dl=0

 

System Specs:

Laptop - Lenovo legion y740

CPU - i7 9750h

GPUs - rtx 2070 maxq(disabled in the config file), uhd 630(enabled in the config file)

RAM - 32GB

SSDs - NVME ssd sn720 512gb, SATA ssd crucial mx 500 1tb.

 

Any help will appreciated.

 

Here's the error image:

WOn4fGg - Imgur.jpg

57Jek8L - Imgur.jpg

Edited by Karen Nikoghosyan
13 hours ago, vltra said:

still blank 
<key>SystemProductName</key>
<string></string>
<key>SystemSerialNumber</key>
<string></string>
<key>SystemUUID</key>
<string></string>

I know I didn't want to share the serial number, it's not blank on my end. Any suggestions?

add kext
CtlnaAHCIPort.kext
IntelBluetoothInjector.kext
SMCBatteryManager.kext
disable
VirtualSMC plugin for moment
after setting new config please reset nvram

Posted (edited)
26 minutes ago, vltra said:

add kext
CtlnaAHCIPort.kext
IntelBluetoothInjector.kext
SMCBatteryManager.kext
disable
VirtualSMC plugin for moment
after setting new config please reset nvram

You mean to remove the VirtualSMC kext?

Edited by Karen Nikoghosyan
10 minutes ago, Karen Nikoghosyan said:

You mean to remove the VirtualSMC kext?

SMCProcessor.kext
SMCSuperIO.kext

disable it for moment. virtualsmc.kext still required

7 minutes ago, vltra said:

SMCProcessor.kext

SMCSuperIO.kext

disable it for moment. virtualsmc.kext still required

Tried with the kexts you suggested, removed those SMCProcessor.kext, SMCSuperIO.kext and still the same issue, it freezes at the same point. BTW i forgot to mention when i was getting those errors the laptop will freeze and the usb light indicator will stop working same as before.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...