Jump to content

HELP! Can't boot into Catalina after reinstalled Windows 10


3 posts in this topic

Recommended Posts

I'm not sure if it is the right place to ask. Tell me where I should move this topic if I'm wrong.

 

I used to have a dual-boot system on separated disks in my hackintosh: Catalina and Windows 10, and it worked fine.

Somehow, I clean reinstalled Win 10 but accidentally in legacy mode yesterday (at this point, I could boot into Catalina still), and I used "mrb2gpt" commend to convert it to UEFI mode. But after doing so, the BIOS setting is reset and I can't boot into Catalina any more, even though I had optimised and changed the BIOS setting. 

After passing through clover boot screen, it stuck here.

IMG_8128.thumb.jpg.745c1e6e677753b2532346cfa504b8cf.jpg

 

I tried adding "Fix 300-series RTC Bug" into my config.plist, and then it stuck here, and soon it became garbled.IMG_8129.thumb.jpg.816e7a3ae391d35f8bc040a357a1dff0.jpg

 

I tried to boot it with my Catalina install USB stick with newest clover and kexts, but it stuck at here and stopped reading.

IMG_8131.thumb.jpg.3f5d88437b3ab88d104e176198f5f48e.jpg

 

Here is my specification of my Hackintosh:

i7-8700

Gigabyte z370m D3H

Kingston KHX2400C15/16G * 2

Asus ROG-STRIX-RX570 4GB

Storage:

Catalina: Samsung SSD 970 EVO 500GB + Toshiba DT01ACA300 3TB (Fusion)

Time Machine: Seagate 6TB Barracuda (Clover bootloader r5108 located)

Win 10: Crucial MX500 500GB

 

And here is my config.plist in Time Machine: config.plist

 

Please Help me...

Posted (edited)
17 hours ago, Hervé said:

You need to mount the disk's EFI partition and replace the boot file (overwritten by Windows) by Clover's. Can normally be done from Windows. The only alternative would be to boot your Clover USB installer and re-install Clover on the disk.

Yeah I tried to do so.

However, for some reason, the USB ports can't match with my original config.plist.

It hangs at "IOUSBHostInterface(0x100000388): matching deferred by IOUSBHostHIDDevice"

But I can't use Hachintool to identify my USB ports because I can't boot into Catalina.

I don't know what to do now....

Edited by ric6121824
×
×
  • Create New...