Jump to content

I can only use either trackpad or touchscreen in Opencore


7 posts in this topic

Recommended Posts

Hrmm, enable VoodooPS2Trackpad and leave VoodooI2C enabled.
It's likely an I2C trackpad, but it should work over VoodooPS2Trackpad, just not as well as it could. You'll need to work through the ACPI patching needed to get it working, but it'll at least work in some capacity.
VoodooPS2Trackpad being enabled should not mess with the touchscreen as it's only over USB.

I'm guessing that you have the trackpad and touchpad buses inverted (ie touchscreen is USB and trackpad is PS2/I2C), as I've never really seen a USB trackpad, and also the first config.plist you provide with a working trackpad has VoodooPS2Trackpad enabled which I'm guessing is providing functionality.

Let me state more clear. I've tried different combination and turn out the following result.

Photo 1

 

Also below is my laptop input spec

ubuntu@ubuntu:~$ dmesg |grep -i 'input'
[    0.617790] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[    0.617868] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
[    0.617918] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[    0.617959] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    0.713073] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input4
[    1.149910] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input5
[    1.457642] input: WCOM484D:00 056A:484D Touchscreen as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input6
[    1.459203] input: WCOM484D:00 056A:484D as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input7
[    1.460933] input: WCOM484D:00 056A:484D as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input8
[    1.461329] input: WCOM484D:00 056A:484D as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input9
[    1.461721] input: WCOM484D:00 056A:484D Mouse as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input10
[    1.462152] hid-generic 0018:056A:484D.0001: input,hidraw0: I2C HID v1.00 Mouse [WCOM484D:00 056A:484D] on i2c-WCOM484D:00
[    1.694046] input: Wacom HID 484D Pen as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input11
[    1.694353] input: Wacom HID 484D Finger as /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-5/i2c-WCOM484D:00/0018:056A:484D.0001/input/input12
[    1.872555] input: Alps Alps Touchpad Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input14
[    1.872954] input: Alps Alps Touchpad as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input15
[    1.873320] input: Alps Alps Touchpad as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input16
[    1.873726] hid-generic 0003:044E:1218.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Alps Alps Touchpad] on usb-0000:00:14.0-2/input0
[  187.570485] input: Intel HID events as /devices/platform/INT33D5:00/input/input17
[  187.571836] input: Intel HID 5 button array as /devices/platform/INT33D5:00/input/input18
[  187.655238] input: Intel Virtual Button driver as /devices/pci0000:00/0000:00:1f.0/PNP0C09:00/INT33D6:00/input/input19
[  188.023990] input: Alps Alps Touchpad Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input20
[  188.027023] input: Alps Alps Touchpad as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input21
[  188.027095] input: Alps Alps Touchpad UNKNOWN as /devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2:1.0/0003:044E:1218.0002/input/input22
[  188.027172] hid-multitouch 0003:044E:1218.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Alps Alps Touchpad] on usb-0000:00:14.0-2/input0
[  188.049974] input: Dell WMI hotkeys as /devices/platform/PNP0C14:00/wmi_bus/wmi_bus-PNP0C14:00/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input23
[  188.545103] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[  188.613622] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input24
[  188.613664] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input25
[  188.613693] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input26
[  188.613729] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input27
[  188.613766] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input28
[  188.613802] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input29
[  352.502585] rfkill: input handler disabled

Btw I tried your method still not work.

 

thx for your reply

 

image.png

Ah

This is indeed a really weird combination. Interesting that it works over PS2. What attaches when using VoodooPS2? VoodooPS2Mouse/VoodooPS2TrackpadSynaptics/Alps/Elans?
This may honestly be a question for the people at the VoodooI2C gitter to see if they can do anything about it.
Another option could be to try and edit VoodooI2CHID.kext/Contents/Info.plist to see if you can get it to not attach - I'm fairly certain you'd want to get rid of "IOKitPersonalities->VoodooI2CHIDDevice Touchscreen HID Event Driver", though there is a lot of personalities listed and I'm honestly not sure what pairs to what functionality.

Edit: You could take a look at this repo as well, it may work with your trackpad: https://github.com/blankmac/AlpsT4USB

Edited by 1Revenger1

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...