Jump to content
2 posts in this topic

Recommended Posts

I'm trying to get Catalina installed on my thinkpad x220 but it always fails. I had it installed a while ago but moved back to windows. I was originally using this clover efi. The install process worked fine with this originally but doesn't anymore

https://github.com/x-t/x220-catalina-efi

 

The installer looks like it works okay and eventually reboots the machine but after rebooting and continuing the install on the black screen with the apple logo it will eventually fail. I tried doing the fix here where users said running the setup tool from terminal again will fix it but it doesn't change anything.

 

https://www.tonymacx86.com/threads/solved-macos-could-not-be-installed-on-your-computer-installer-resources-error.263961/

 

 I thought it might be an issue with the EFI so tried to use this opencore one instead but it when using this I get the same problem where the install will eventually fail. Does anyone have any ideas on fixing this? I'm making the install usb with dosdudes catalina patcher. I tried using the install app the patcher downloads and also tried using once created from the newest updates with gibmacos. I'm formatting the drive to apfs also so i'm not sure what the issue is

https://github.com/tluck/Lenovo-T420-Clover

 

Edited by NO_obsctruction
Posted (edited)

It also fails with mojave with a similar error message i think its something to do with SIP because of dosdudes patches but I have that disabled via the config.plist the install log says


 

NSLocalizedDescription=archive verify failed}}} {

NSFilePath = "/Volumes/Mojave/.OSInstallSandboxPath/Root";

NSLocalizedDescription = "An error occurred while extracting files from the package \U201cCore.pkg\U201d.";

NSURL = "Core.pkg -- file:///System/Installation/Packages/OSInstall.mpkg#Distribution";

NSUnderlyingError = "Error Domain=PKXARArchiveErrorDomain Code=101 \"archive verify failed\" UserInfo=

 

 

Is the archive verify failed a SIP issue?

Edited by NO_obsctruction

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...