Jump to content

Kernel panic on i3 1005g1 Notebook (Catalina)


3 posts in this topic

Recommended Posts

Hi,

 

I'm trying to install Catalina on an Ice Lake Notebook (i3 1005g1) but I couldn't get past the attached kernel panic screen. 

 

I have tried making some adjustments such as -

 

EnableWriteUnprotector -> True
RebuildAppleMemoryMap -> False
SyncRuntimePermissions -> False

 

Also tried changing SystemProductName from MacBookAir9,1 to MacBookPro16,2.

 

I have attached my EFI and OC log here. Can anyone please check and let me know what I'm doing wrong here?

 

Thanks.

IMG_20210301_022537.jpg

EFI.zip opencore-2021-03-01-020756.txt

If you experience an Invalid frame pointer kernel panic early in macOS boot on an Intel 10th Gen Ice Lake system, it is most likely a memory map related issue.

 

You may need to set the DevirtualiseMmio option to True and set the MmioWhitelist for a specific MMIO.

 

686458940_2021-03-044_26_30.png.b9a7c3dc9d60706f8bf41ee862a8f539.png

 

https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/extended/kernel-issues.html#kernel-panic-on-invalid-frame-pointer

 

Fortunately, looking at the log file, I was able to check the MMIO address because it is the Debug version of OpenCore.

09:642 00:017 OCABC: MMIO devirt start
09:658 00:016 OCABC: MMIO devirt 0x70800000 (0x5F800 pages, 0x8000000000000001) skip 0
09:675 00:016 OCABC: MMIO devirt 0xFC800000 (0x2000 pages, 0x8000000000000001) skip 0
09:692 00:016 OCABC: MMIO devirt 0xFED00000 (0x1 pages, 0x8000000000000001) skip 0
09:708 00:016 OCABC: MMIO devirt 0xFED10000 (0x8 pages, 0x8000000000000001) skip 0
09:725 00:016 OCABC: MMIO devirt 0xFEDA0000 (0x2 pages, 0x8000000000000001) skip 0
09:742 00:016 OCABC: MMIO devirt 0xFEE00000 (0x1 pages, 0x8000000000000001) skip 0
09:758 00:016 OCABC: MMIO devirt 0xFF500000 (0xB00 pages, 0x8000000000000001) skip 0
09:775 00:016 OCABC: MMIO devirt end, saved 1608752 KB

 

I processed MmioWhitelist for address 0xFF500000 in your Config.plist.

Replace it with the Config.plist attached below and reboot.

config.plist

 

1716668384_2021-03-044_11_11.png.2e00f0e74d83a3c8e0060f0d15ce8c1f.png

 

If you are still experiencing the same Invalid frame pointer kernel panic, try each of the two combinations below.

 

- MmioWhitelist Combination 1 -
MMIO devirt 0x70800000 (0x5F800 pages) = False
MMIO devirt 0xFC800000 (0x2000 pages) = True
MMIO devirt 0xFF500000 (0xB00 pages) = False

 

- MmioWhitelist Combination 2 -
MMIO devirt 0x70800000 (0x5F800 pages) = True
MMIO devirt 0xFC800000 (0x2000 pages) = Flase
MMIO devirt 0xFF500000 (0xB00 pages) = False

 

Also, I added the -igfxvesa boot arg to boot-args in the NVRAM section of Config.plist to prevent DVMT related kernel panic and other problems in the ICLLP Framebuffer.

I hope your problem is solved well. :)

Edited by shl628

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...