Jump to content

AppleALC configuration for CX20585 - no internal microphone


1 post in this topic

Recommended Posts

Hello guys,

I have been struggling with the internal microphone on my hackintosh for a very long time. I added my own layout, platforms and changed pinconfig in AppleALC and... Internal speakers, headphones and line-in works like a charm. But no luck with internal microphone - it's only detected, but no sound is captured. I also tried injecting layout-id in DSDT but no luck either. Any ideas?

 

Bootargs: alcid=4 alcdelay=1000
Laptop: ASUS K52JT
OS: High Sierra 10.13.6
Codec: CX20585
layout-id: 4 - custom, based on 3 which worked, but only for speakers and headphones
PinConfig: 01971c1001971d1001971e2101971f0401a71c2001a71d0101a71ea001a71f9001b70c0201b71c3001b71d1001b71e8101b71f0401c71cf001c71d0001c71e0001c71f4001d71cf001d71d0001d71e0001d71f4001e71cf001e71d0001e71e0001e71f4001f71c4001f71d0101f71e1701f71f9002071cf002071d1002071e0002071f4002271cf002271d1002271e0002271f4002371cf002371d1002371e0002371f40
WakeConfigData: 01b70c02

 

Linux dump, layout, platform are in attachments.

Platforms4.xml layout4.xml cx20585.txt

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...