Jump to content

OpenCore + H470 + Comet Lake + Catalina 10.15.7 : UHD 630 graphic acceleration not working


3 posts in this topic

Recommended Posts

Hello !

This is my first hackintosh, and I’m a total noob at tinkering bootloaders. I managed to install Catalina on my computer using OpenCore and the great Dortania's guide, but I have an issue with the UHD 630 graphic acceleration.

 

Hardware :

Gigabyte H470 HD3

Intel Core i5 10400

GPU : integrated UHD 630

Samsung EVO SSD 970 1TB 
DDR4 Corsair Vengeance LPX 2x4Go

 

OS Catalina 10.15.7

 

First, after booting on my USB and the verbose mode, I had a black screen before installation. I tried different platform-id : 07009B3E, 00009B3E, 0000A53E…

But still had this black screen.

Then, I tried to add the boot argument -igfxvesa to force the GPU into VESA mode, and after that no more black screen issue, and I have been able to install Catalina with success, but with my UHD 630 in VESA mode.

So I have two questions :

1/ I copied the EFI on the hard drive and now I'm able to boot without the USB. I wanted to know if I make changes on my config.plist that lead to a black screen, will I be able to boot Catalina again on my hard drive when I plug the USB installer ? In other words, will the USB bootloader prime to the hard drive bootloader ?

2/ What to do for having my UHD 630 graphic acceleration working ?

Thanks in advance for your answers !

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...