Jump to content

Atheros AR9285: not working in Big Sur


2 posts in this topic

Recommended Posts

  • Hervé changed the title to Atheros AR9285: not working in Big Sur

I assume you're aware that Apple dropped support for Atheros cards in Mojave and, since then, the minimum required is to install Atheros40 kext from High Sierra. If you want proper assistance, you'd need to detail what you use, what you've installed; ideally post a zipped copy of your boot loader EFI folder.

 

I use an AR9280-based card in my old Dell Vostro 200 desktop running Catalina. All I had to do was cache 10.13.6's IO80211Family kext from /L/E as detailed here. In your case, just try to inject it from your bootloader's kext folder; if you're using OC, don't forget to declare it with all its PlugIns in the config, knowing that you'll just need to enable the main kext and the Atheros40 PlugIn.

 

Or try the modded/patched versions available here:

https://www.insanelymac.com/forum/files/file/1008-io80211family-modif/

https://github.com/khronokernel/IO80211-Patches

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...