Jump to content

Sony Vaio NVIDIA GT540M OpenCore Inject Nvidia Black Screen Error


2 posts in this topic

Recommended Posts

Hello to everyone with clover bootloader installed on macos sierra. When I try to run it with opencore bootloader the image turns black after the verbose screen. I tried it from the hdmi port in the same way. but I can connect to vnc. 1 minute after connecting with vnc the computer hangs. I will be glad if you help.

i am using legacy bios. i don't have uefi on my computer.

ioservice export clover boot loader.

 

Specs Page:

https://www.sony.com.tr/electronics/support/laptop-pc-vpc-series/vpcf22s1e/specifications

 

Sony Vaio VPCF22S1E

Intel® Core™ i7-2630QM

Sony Geforce GT 540M 1GB

8GB DDR3 1333 Memory

 

Thanks.

 

IOServiceSonyClover.zip opencore.zip

On 1/11/2021 at 3:13 AM, Cerbereus said:

My device is not optimus. single gpu.

I solved the nvidia problem by looking at the reg file I received from clover, adding to the opencore device property. there is currently no problem with the image. It works including the hdmi port.

 

but now there is a problem like the device does not see smbios and memory. I tried many smbios but didn't get any results.

 

How should I go about it?

 

Thank you.

 

 

Ekran Resmi 2021-01-10 23.10.30.png

Ekran Resmi 2021-01-10 23.11.08.png

Ekran Resmi 2021-01-10 23.11.27.png

config.plist 31.79 kB · 2 downloads

Where did you get the value of GT 540M in device properties?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...