Jump to content

Dual Displays (not mirrored) on Intel UHD Graphics 630


2 posts in this topic

Recommended Posts

I have managed to get an OC 0.6.5 build installed and running, but have an issue with the iGPU.

 

I made a github repo and an issue here that I will track my progress and collect info from various forums:

https://github.com/gotjoshua/Hackintosh-Intel-i9-10900t-AsRock-Z490-Phantom-ITX-TB3-iGPU/issues/1

 

Here is the commit that shows the changes i needed to get it booting with OC 0.6.5 (the original repo that i forked from hung halfway through the apple loading bar):

https://github.com/gotjoshua/Hackintosh-Intel-i9-10900t-AsRock-Z490-Phantom-ITX-TB3-iGPU/commit/ad7faeccaa5542ae453e421b35be9be7a16d8946#diff-18ce8f2001c3c18075dbf54219a44cbfbc93fc79f0f2ab519305ed1bcd16112eR190

 

 

So the situation is like this:

I can boot and Catalina runs great - mostly.

But some apps eg PathFinder and NovaBench crash immediately with this:

 

Application Specific Information:
Assertion failed: (0), function CreateCompiler, file /Library/Caches/com.apple.xbs/Sources/GPUDriversIntel/GPUDriversIntel-14.7.11/GLRenderer/kbl/usc_interface.cpp, line 1676.
 

 

I am able to avoid these crashes via a fake device-id as suggested in this thread, but then i only have one adapter output and can only use mirroring for the two displays.

 

Any help out there?

Does this actually deserve a bug report / issue for WhateverGreen ?

 

My build description is here:

 

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...