Jump to content

AMD RX580: Need Help Post-Install Big Sur OC 0.6.4


3 posts in this topic

Recommended Posts

Hi,  I'm new to this forum, and need some help.

 

I have a working 0.6.4 Big Sur install, and I'm trying to get the boot selector GUI to work properly. It works, but I have not been able to get the display resolution to work properly.  I can make it work in either huge graphics (very low res) or in a better but still big but awkward resolution (things are stretched sideways).

 

I have an RX580 graphics card and need to have my iGPU disabled (Iris Pro 6200 of i7-5775c CPU), otherwise the system will not boot.

There are various settings in the config.plist I have tried, but nothing works well.  I have tried a lot of combinations.

I have set the following device property in order for it to work in the weird wide resolution:

  • PciRoot(0x0)/Pci(0x2,0x0): AAPL,ig-platform-id = 04001204  (this should mean the gpu is not driving the display)

 

The rest is per OC guide for Opencanopy

BuiltinGraphics

resolution == > max etc etc.

What am I doing wrong ??

 

I have also tried giving it a given resolution, say 2560x1440@60, but it won't recognize any numeric setting, not even 1920x1080@60.

 

Thanks

Hello Hervé,

 

Thanks for the reply.  As things stand I have a SMBIOS for an iMac15,1.  I will try it as an iMac16,2

 

The guide I followed was for Haswell/Broadwell, I will try Haswell-E also instead, see how that goes.  I agree both the iGPU and dGPU should be supported.

 

My setup is:

i7-5775c

Gigabyte z97x-Gaming 7

RX 580 8Gb

32 Gb Ram

 

BTW I never meant the framebuffer setting would not drive the display I simply took that setting from the Haswell Dortania guide:

 

"AAPL,ig-platform-id    Comment
0300220D    Used when the Desktop Haswell iGPU is used to drive a display
04001204    Used when the Desktop Haswell iGPU is only used for computing tasks and doesn't drive a display
07002216    Used when the Desktop Broadwell iGPU"

 

Due to the fact that I had to turn the iGPU off, I thought this was the better setting option.  I did try 07002216, with no result, endless reboot and weird resolution, it reboots once the Apple logo shows up.  At least that setting 04001204 booted.

 

I chose Haswell/Broadwell guide instead of Haswell-E guide because the guide for Haswell-E assumes the CPUs don't have an iGPU :

 

"By default, the Sample.plist has this section set for iGPU and Audio. We have no iGPU so PciRoot PciRoot(0x0)/Pci(0x2,0x0) can be removed from Add section. For audio we'll be setting the layout in the boot-args section, so removal of PciRoot(0x0)/Pci(0x1b,0x0) is also recommended from both Add and Block sections."

 

So based on that, and considering the Haswell/Broadwell guide did mention the existence of my iGPU (07002216), I went with that guide.

 

I will try a mish-mash of both guides, Haswell-E guide throughout, but with iGPU setting using 07002216 taken from the device properties in the Haswell/Broadwell guide.

 

Please let me know if you have any thoughts or comments.

 

Thanks again,

 

Manuel

Hi,

 

I just finished updating a few things, now SMBIOS is iMac16,2, 07002216 for iGPU, and I can boot while having both GPUs but still no cigar on the resolution.  I can't change it from UEFI - Output in the config.plist

I am attaching a zip of config.plist, as all efi is over the 10mb limit, any help would be very welcome.  This is the last bit for an otherwise very good and stable install.

 

Thanks

 

Manuel

config.plist

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...