Jump to content

Opencore 0.64 fixing sleep for 4k displays


2 posts in this topic

Recommended Posts

I am using SSDT-PLUG, SSDT-EC, SSDT-SBUS-MCHC and SSDT-PMC - using Opencore 0.64 with iMac19,1 smbios for my B360 Aorus with i7-9700k. USB mapping kext included in boot.

Sapphire Pulse RX 580 (2 4k monitors using 2 DP ports) & UHD 630 headless mode

Sleep works fine. But after wake up, keyboard and desktop powers on but black screen on my 4k monitors (Dell and LG)

Per the link below, I have to disable AGDC in my dGPU

https://dortania.github.io/OpenCore-Post-Install/universal/sleep.html#fixing-gpus

If I use dgpu device properties with CFG,CFG_USE_AGDC, it boots and won't get to login screen - screen goes black.

If I use only CFG_USE_AGDC, it boots normal but when I type IOReg -lw0 | grep "CFG_USE_AGDC" I still get output "CFG_USE_AGDC" = Yes

 

Opencore suggests using SSDT to disable and I tried adding SSDT along with WEG and still unable to disable AGDC in dGPU. WEG introduced igfxagdc=0 boot arg to disable but I believe this is for IGPU which I am not using. I tried it anyway but didn't work.

Or use device property disable-agdc but no details on how to add - will it be boolean no? I have disabled RC6 Render Standby in Bios. Sleep works with windows installed in another nvme drive, so I hope my bios settings are correct.

 

Anyone with 4k monitors connected to display ports who fixed wake from sleep? Please help.

 

DefinitionBlock ("", "SSDT", 2, "APPLE ", "SSDTAMDG", 0x00001000)
{
    External (_SB_.PCI0.PEG0.PEGP, DeviceObj)    // (from opcode)
    Scope (\_SB.PCI0.PEG0)
    {
        Device (PEGP)
        {

Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03                                           
                    })
                }

                Return (Package (0x1C)
                {
 

  "CFG_USE_AGDC", 
                    Buffer (One)
                    {
                         0x00                                             
                    }, 
 

Edited by sam298
×
×
  • Create New...