Jump to content
madman

OpenCore 0.6.3 - Hide Partitions

4 posts in this topic

Recommended Posts

I recently switched to OC and everything runs stable. Now it is the time for customization :) 

 

Everytime I boot I see two Windows Partitions in the picker. I can only boot one, but it shows up one more. If I click on the other one, nothing happens, it returns to the OC Boot Screen.

 

How can I hide this partition? I tried HideAuxiliary, but it didn't work. 

 

Quote

                     key>Misc</key>

                        <key>HideAuxiliary</key>
                       <true/>

...........                

 

            <dict>

                                <key>Arguments</key>

                                <string></string>

                                <key>Auxiliary</key>

                                <true/>

                                <key>Comment</key>

                                <string>not needed</string>

                                <key>Enabled</key>

                                <true/>

                                <key>Name</key>

                                <string>Windows1</string>

                                <key>Path</key>

                                <string>PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0)/Ata(0x0)/HD(3,MBR,0x808C3AA3,0x1BD7C800,0x1A6800)</string>

                                <key>TextMode</key>

                                <false/>

                        </dict>

IMG_3297.HEIC

 

FS0 is my Mac Boot Partition. The HD(2 MBR is the correct Boot Partition for Windows. Any ideas?

 

Edited by madman
Share this post

1 hour ago, madman said:

How can I hide this partition? I tried HideAuxiliary, but it didn't work. 

In config.plist Hide Auxiliary=Yes if you want then to show temporarily just hit the space bar at the Boot Menu. See attached.13163840.thumb.png.fbd0396716cb2a7d021bef9e4b19ee7b.png

Spoiler

216196971_Screenshot2020-11-18at22_09_04.thumb.png.b2f351774776a47b6a7f8da26fa863d7.png

Spoiler
Spoiler

13165728.thumb.png.efbc26c3257b60307882d127f58c5ee7.png

 

 

 

Edited by eSaF
Share this post

1 hour ago, madman said:

Thank you, I did that and it works with the UEFI Shell and Reboot. The thing is, I can't disable one HDD MBR with this method. Is there maybe something wrong with the syntax I used? 

I may be wrong here but am I guessing that your installation is a legacy one as I see you mentioned MBR in your post. If your motherboard has UEFI capability why is the installation a legacy one, maybe that is the problem also you need to complete your machine specs in your profile to aid members to help with any problems you are having.

Share this post

×