Jump to content

[SOLVED] Asus PRIME Z-490-P i5-10400 - black screen after IOConsoleUsers: gIOScreenLockState 3


1 post in this topic

Recommended Posts

It's my first OpenCore setup, I've been using Clover so far. I followed the Dortania install guide for Comet Lake. Installation boots in verbose mode and reaches IOConsoleUsers: gIOScreenLockState 3. Then the screen turns black. So it looks like the system is trying to enter graphics mode but it fails. I know that system does not hang because if I wait a few minutes then the system goes into sleep mode (I see the led blinking). If I press any key then the system wakes up, but the screen remains black.


So far I tried:

  • Changing AAPL,ig-platform-id value from 07009B3E to 07009B3E
  • Adding agdpmod=pikera to boot args
  • Changing iGPU BIOS setting from Auto to iGPU only


OpenCore 0.6.3, All kexts up to date, downloaded from Github.


// EDIT:

Problem solved thanks to fb patch:



There is also igfxonln=1 argument required in boot-args. Otherwise, I got a black screen after wake up from sleep.


Edited by wujek_bogdan
  • Like 1
Link to comment
Share on other sites


  • Create New...