Jump to content

Issues with "accountsd" and "commerce" Services after 10.15.7 Update


6 posts in this topic

Recommended Posts

I recently updated both my systems (an i9 10850K Desktop and a Lenovo T530 Notebook) to macOS 10.15.7 and after that I noticed 400+ per cent CPU utilization of the service "accountsd" in combination with "commerce". Once I force quit commerce everything returns to normal for a ffew minutes until the commerce service restarts automatically

 

I've read this issue could be related to:

 

• iCloud (which I don't use)

• Apple Mail / MS Exhcange (I dont use Exchange)

 

I deleted all my eMail Accounts and recreated them but the issue still remains. I read somewhere that reinstalling the 10.15.7 combo-update should fix the issue – it doesn't. Renaming the service impossible because it is protected. It's located at: /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/commerce 

 

Any insight on this topic is highly aprreciated

Bildschirmfoto 2020-09-27 um 22.52.57.jpg

I removed the Apple ID as well on both of my systems (I have a Lenovo T530 Laptop as my office computer)

 

Then, I tried to log in via System Preferences but it wouldn't let me because I don't use 2-way-authentication.

 

My workaround was to login via the App Store which worked without problems. The problem has gone since then and everything is back to normal.

Edited by 5T33Z0

Was same on my 10.15.6 Acer, and on 10.15.7 desktop (almost at the same time). I didn't do anything and the desktop returned to normal after a restart.

My notebook however remained the same after several restart and interestingly today the issue is gone. idk what was that

Possible Fix for those still having Problems by jimsalabim from the german hackintosh forum:

 

sudo -v
killall -9 accountsd http://com.apple.iCloudHelper
defaults delete MobileMeAccounts
mkdir ~/Library/Accounts/Backup
mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/
killall -9 accountsd http://com.apple.iCloudHelper
sudo reboot

 

×
×
  • Create New...